GRBL error code Feed rate has not been set or undefined

Hello new to carbide and running v carve desk top and shapeoko 3 xxl and getting this error code not sure if something i am doing wrong or the file or machine

Hi Danny,

You’ll need to tell us what post-processor option you are using in VCarve, and post the g-code file for analysis.

Also, this same error was discussed in this thread.

1 Like

someone said that the shapeoko should be there to select but it’s not so i chose the cnv shark usb post processor

not sure where the g code is there is a v carv file this is a new xxl and i down loaded the latest carbide motion

  • you should have a Shapeoko post processor, it comes with VCarve.
    Can you go to the File menu, and select “Open Application Data Folder” and check if in the “PostP” subfolder, you see “Shapeoko_inch.pp” and “Shapeoko_mm.pp” files ?

  • G-code is the file you tried to load in Carbide Motion, that gave you that error. Post it here (in a post, using the “Upload” button

1 Like

there is a Shapeoko_inch.ppShapeoko_inch.pp” and “Shapeoko_mm.pp” files ” anV-Carve 60-deg.tap (338.2 KB) how do i load it in to v carv

Ok. And when you browse the list of post-processor in the pull-down list of the “Save toolpath” menu, you don’t see them ?

Can you please check, I might have another trick for you in case you really don’t see them in the list.

yes its there but not sure how to save it Shapeoko_inch Shapeoko_mm.pp

So I did not quite understand what you meant by “how to save it” ?

You just have to select it in the drop-down list:

and then it should become the default choice.

Vectric has included a “post-processor” for the Shapeoko (a pair of them actually, one for Imperial measure, one for metric) since v8.5 — please let us know if you have any difficulties accessing them. Their “install” procedure is to move the one you want to move into a specific directory and then that one will be used and the others ignored:

  • “C:\ProgramData\Vectric\VCarve Desktop\V9.0\PostP\Shapeoko_inch.pp”
  • “C:\ProgramData\Vectric\VCarve Desktop\V9.0\PostP\Shapeoko_mm.pp”

copy whichever of those you would prefer to use into

  • C:\ProgramData\Vectric\VCarve Desktop\V9.0\My_PostP

and then it’ll be the only one you see. (Note that the numbers in those file paths may need to be adjusted to match your version)

Here is a basic tutorial overview: Vectric tutorial overview

If you have a BitSetter you’ll either want to edit the post-processor to support tool changes, or to use one which does, please see:

its not in that list i whent to file and appclation data ant it in there but not showing up under post processor under save tool paths

follow @WillAdams’s tips and you should be good, this is the tip I had in mind:
same as before, “Open Application Data Folder”, create a new subdirectory called “My_PostP”, copy and paste the two Shapeoko pp files you mentioned earlier in there, restart VCarve, it should work.

i tried the same thing but i copped both files in to the the tool data base that my other post processor and re started and they are there thanks for all you help

1 Like

Very new to this and upgraded to new machine and now another learning curve

This topic was automatically closed after 30 days. New replies are no longer allowed.