GRBL error. Cutter not found

I have to admit that I’m “challenged” when it comes to this stuff. But my board has a blue light and nothing else. My computer doesn’t even acknowledge the USB plug when I plug it in or unplug the machine. Tried 2 other cords. Have latest version of cabide motion. I think my board is bad but I can’t remember if the blue light is the only light on the board. Also once I power the machine up the motors lock up and there is a very feint hum. Any suggestions before I start to bug the tech support guys?

Sounds good thus far.

Please go through the machine operating checklist:

Note what you do at each step and what happens. Provide that information here, and to if things don’t work — we’re glad to work w/ you to crowdsource a solution for you, but you have to work w/ us to provide enough information for us to provide meaningful suggestions, and you need to be willing to try them and report back on what does or doesn’t happen. Also, support needs to know about instances where machines don’t work, whether that’s due to unclear instructions, difficulties w/ the software or the machines or the firmware, or local environmental issues so that they can improve their documentation, and work to prevent these sorts of issues from recurring for others.

One thing to check on a windows computer, is look in “Device Manager” (Right click on “This PC” select Manage and select Device Manager in the left window pane). Make sure the USB cable is plugged in. You should see the Shapeoko 3 in the Ports (COM & LPT) section:

I also get a steady blue light on mine.

1 Like

Everything checks out till step 7. I obviously can’t go any further than that because it doesn’t seem like the board is powering up.

The machine gets power in two different ways:

  • over USB to power the Arduino — I believe this lights up the blue light
  • through the power supply to power the stepper motors — I believe this is what locks the motor and creates the hum

There’s a power switch for the latter — make certain that it’s switched to on. Not sure if the current power supply is auto-switching — if it’s not, make certain that the switch on it is set to the correct setting for your local electric grid.

Please e-mail and they should be able to square you away if it’s something which needs to be replaced.

I guess I haven’t been as clear as I should. When I got the machine I set it up and did my shapeoko logo and my coasters. Everything worked fine. I put it away for about 6 months because I couldn’t figure out inkscape. I finally got my head around that program and went to use it it doesn’t work.on my other arduino boards there is a power light and then there I s a rx light that flashes. On the shapeoko board I only get the blue light. It seems to come on when I power the machine. My laptop doesn’t even recognize that there is anything plugged in to the USB port when I plug into shapeoko. I have verified that it’s not USB plug by plugging in other devices. I can’t remember If the board just had a blue light or if it had other lights when it fires up.

I’m pretty sure that there’s a light and some blinking which should accompany plugging in the USB so as to power up the Arduino.

Please do as @UncommonDad noted and check your Windows install that it is properly accessing the Arduino on the Carbide Motion board properly.

Indeed, there are comm activity LED’s on my CM controllers… have you verified the Device Manager recognition of your controller? This driver gets bolted in with CM installation (I believe).

1 Like

I will be fine tooth combing my software tonight when I get home.

no. device manager does not register when I plug machine in. I plugged two different Arduino boards in and it recognized them

Have you installed Carbide Motion?

Yes, the latest version.3.0.364.

Try standard Windows trouble shooting

  • reboot
  • reinstall device drivers
  • reinstall the app
  • try as admin
  • uninstall, reboot, reinstall

ok, rebooted computer…same.
uninstalled and reinstalled carbide motion…same.
device drivers???
uninstalled carbide motion, rebooted, reinstalled…same.
try as admin? not sure how to do that…I thought I was admin(only one on this laptop).

right click installer app, pop up menu should provide “run as administrator” option

1 Like

and if those things don’t help, please either try a different machine, or contact, enumerating all the things which you’ve tried thus far.

Thanks for all the help!

Sent email last night to support. …do they take a while to get back to you?

I’d recommend manually installing the driver if I knew where there was a repo or URL to grab it from. And yes, give the Carbide Team some response time allowance… they’re a busy crew.

I take it running the CM installer as Admin failed to bolt in the driver? There’s an explicit step/dialog during the install that performs this operation (IIRC).

1 Like

I am having the exact same problem as Ken. I wonder was the problem ever fixed and what do I have to do to fix my connection error.