GRBL Error: EEPROM read failed. Reset and restored to default values

I just got my shapeoko 5 pro and after some wiring issue I got it running and functioning correctly … sort of. I keep getting this error during initialization or setting zero. Because of this I don’t think the Z axis gets set properly. I can’t really find any useful info online. I’ve already emailed support but wondered if anyone here has any idea. It’s running on a MacBook Pro.

just a follow up here … it appears that i can in fact operate the machine ok but i have to initialize it EVERY time. but i can click through the error and proceed. i tried a different usb to usb C adapter, no luck. my only other thought is maybe trying a different computer (windows).

edit i dragged a windows desktop into the shop. hooked it up. ran through initialization and got the error window twice after doing the initialization (without the bit setter). so its not the computer.

I think you should be able to eliminate that by going to the settings window and downloading the config to the machine again.

1 Like

yeah i have tried that several times, from multiple computers. whatever stores the state or config on the controller is not working.

i don’t know if this is related (doubt it) but the rear left stop sensor wasn’t working out of the box. the part of the wiring harness that connects to the sensor was terminated in the wrong order. i used a small amount of wire to correct this and the sensor works normal now but i wonder if there are other issues.

Let us know about all this at and we’ll get this sorted out as quickly as we can.

yep i have an email thread with Brandon but wanted to post on forum to see if it was something stupid i was missing.

folks here sent me a new controller no questions asked with shipping to return the original. i swapped them and all my errors went away. great support, thank you!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.