GRBL ERROR: Homing Failed, couldn't find limit switch on Z-PLUS

Good morning everyone,

This would only happen once in a blue moon in the past, but now it won’t home at all and I am stuck. When the Z-Axis homes during the initialization phase, it moves to the very top and then vibrates until an error occurs. I found a post from 2018 but the switches are different. Does anyone know what’s going on with my Shapeoko 3 XXL? I am running it with the new Z-Plus.

VIDEO: https://vimeo.com/433347333

Thank you,
Brian

Hi @Ustayclassy,

power off the machine, lower the z manually (by turning the ballscrew with your finger), until you have an inch or clearance, and retry.

If it does the same, power off, lower the Z manually again until you have access to the limit switch

image

Then power on the machine, but don’t home/initialize, just connect.
Then go to the Settings menu, bring a piece of metal in front of the proximity switch, and check if the LED on the switch lights up, and it you see a mention of the Z limit switch being triggered on CM screen

4 Likes

Thank you for your quick reply!

It did the same so I lowered the Z manually and tested the proximity switch in the Settings menu. The LED did NOT light up, and there was no mention of the switch in the CM screen.

Ok, so the Z limit switch is not working: it’s either not getting power from the board, not returning its signal, or it’s dead (unlikely). I would first check the connection at the controller board, is it seated properly there ? It may have gotten loose. Maybe unplug it and replug it and redo the manual test?

4 Likes

I have checked the connection at the control board, and eveything appears to be seated properly. I unplugged everything and tried the test a number of times.

Do you think it need to be replaced?

You mentioned that this happened “once in a blue moon” earlier, so I suspect you had a half-bad connection somewhere between the switch and the controller, and now it has gone full bad I guess.
If you haven’t done so already, contact support@carbide3d.com and they’ll work with you to sort this out

In the meantime you could, for the sake of testing that the controller itself is fine, plug one of the other switches (X or Y) in the Z switch connector, redo the manual CM test (this time triggering the other switch you plugged, of course), and check that when you do that you do see CM reporting an active Z switch?

3 Likes

The controller seems fine. I plugged the X-Switch into the Z-Switch connector and it reported an active Z-Switch (while triggering the X-Switch). I will contact contact support@carbide3d.com now.

Thank you for your help.

Without triggering switch?

I triggered the X-Switch.

1 Like

Check the order of the wires at the connector for the Z switch. Confirm that it matches the working ones.

1 Like

Do you know of any way I can use the machine without the Z-Switch for a few jobs?

They match. I’ve done over 100 jobs without any issues. Now it appears dead

Interesting thing happened. I unmounted the Z-Switch and plugged it straight into the controller itself, and it worked! It appears that the wiring from the switch to the controller is bad…

5 Likes

Hey Everyone, I figured out the problem!!!

After 3-4 months of use the soldered wires near the little white wire connectors broke from repeated micro movements. I striped the wires, hardwired them, and applied shrink tubing – and everything works again! Thank you for your help, I am happy it’s up and running again!

Respectfully,
Brian

4 Likes