GRBL Error: Homing failed, couldn't find limit switch

Getting this… “GRBL Error: Homing failed, couldn’t find limit switch”.
Then…“Homing cycle failed”
On Shapeoko 3
I put a piece of metal in front of the three proximity switches and they all give a red light. The Z axis switch light is a little on the dull side. Just got the machine and using Carbide Motion 5. Thanks

Please see:

https://wiki.shapeoko.com/index.php/FAQ#Homing_switches

or write in to support@carbide3d.com and let us know all the things you’ve done.

Can you get a pic of the connector at the controller? Possibly a switch connector that’s wired incorrectly.

1 Like

It’s wired fine, just like the picture, but can someone tell me how they work. The machine just got here and I used Motion 5. All three lights are out but go red when I put metal in front of them. What does the controller look for? Will the controller initialize if the limit switches were not mounted, just connected? Why would it matter if they weren’t? Do I have the wrong software? My settings screen does not look like the one in the assembly guide. My screen is not black. Did I do the settings wrong? Would that matter? What does “Couldn’t find limit switch” mean? Is that one, or more? Is one defective?

Thanks

the youtube video is not helpful since that is for 2 wire switches and I have 3 wire switches and the connector is totally different as well.

It works like this:

  • each switch, when wired correctly which seems to be the case here, will close the circuit between two of its three wires when it detects metal close enough in front of it.
  • the controller checks whether each switch reads as “open” or “closed” (triggered).
  • upon initializing the machine, the controller moves the X, Y and Z axes towards the back right corner and up, UNTIL it detects that the X,Y, and Z switches have been triggered, then it knows it moved far enough to reach the limits, and finally it pulls off a few mm from there, which completes homing.
  • the error you are seeing is the controller telling Carbide Motion that it did not detect one or more of the limit switches being triggered, even after moving the axes for a while, so it gives up.

First of all, are the axes moving in the right direction when initializing ? the machine should travel to the right, towards the back, and the router should move up. If one direction is reversed, then it (obviously) won’t trigger the switch on that axis, and then it’s probably a matter of machine configuration (by the way did you send machine configuration from CM settings menu?)

Then, redo that manual test where you bring a piece of metal in front of each switch, and this time also check whether Carbide Motion “sees” it being triggered: go to the Settings tab, there is a line there that displays which axis is being triggered. Verify that the X, Y and Z axis are shown as triggered consistently.

If the Z axis fails to register consistently during that test, then something is amiss in the wiring of that switch, could be a loose wire in the connector. The dull light could indicate that the prox switch is not getting the nominal voltage to operate properly, which could be due to a poor contact somewhere.

If the machine does move in the right direction on each axis, does it go on until it contacts and makes an awful brrrrrr sound ? If so, it would mean that one switch may not be positioned quite right mechanically, and does not get to trigger before the plates contact. In this case just realigning the switch to bring it closer (to the metal edge it is supposed to detect) usually fixes this.

If none of this helps, definitely contact support@carbide3d.com as @WillAdams said.

Now that was informative. Thanks.
When I turn on power to the machine it give a very audible grunt. Doesn’t really move. When I click “Initialize” it remains dead still, all motors, nada. In about 2 to 4 seconds the error message pops up.
So the machine is supposed to “go home” and “home” is the back corner. That explains a lot especially by what they mean calling it “initialize”. I think I have a bad controller or bad software.

if it’s a single short grunt, that is probably normal, it’s the steppers locking in place.

As expected. When just turning on the machine, it should stay still (after the steppers lock in place, which can move the axes ever so slightly)

Allright. It’s most probably not the software, since you were able to “Connect”.
Can you confirm that you did go and send the machine configuration from the Settings menu as per the instructions ? You mentioned:

Can you upload a screenshot of your settings page, just in case ?

If nothing happens when you click initialize, then it’s likely a problem with the stepper motors wiring at the controller, and if so your best bet to see this through is to contact support, so that your issue is tracked and they can help troubleshooting that with you more efficiently.

Sorry I forgot to mention, when I click “Initialize” the machine grunts for about 3 seconds, then stops making noise, and in another 2 seconds the error message comes up. Here are pictures. Note my setting screen (different from the manual). The program wouldn’t continue until I put these “travel dimensions” values in. I just hit “load defaults” to get these settings and that’s where they came from.

Allright so the stepper motors do move, the 3 second grunt is one of them trying to push the gantry or X/Z plate farther than it can go, because the limit switch failed to trigger.
Two things:

  • In that Settings page the does “GRBL Active input pins” section display “X”, “Y”, and “Z” when you manually trigger the prox switches with a piece of metal?
  • with the machine turned off, if you slowly pull the router and gantry away from the back corner, then turn on the machine and initialize, does the movement happen normally until it starts doing the grunt sound? If you could capture a short video that would help

Did you also send the Grbl configuration?

Here is the Y proximity switch “off” and with metal in front “on” glowing red (pardon the color shift to orange) and here is

the X switch “on” but sort of not bright. So they all are getting power. Thanks

Yes but what about the display in settings page, does X show up as triggered there?

Looks like you’re at the bottom of your Z travel. Machine probably going the wrong way and stepper is losing steps.

1 Like

OK I’m a dope but I get a lot of help achieving that appellation. The problem is the Z axis was not set to “Z-Pluss”. Sorry I just glazed over this part but when I came to the white screen it is totally different from the black one in the manual. So I just winged it. I figured it must be “lead screw” and certainly not belt drive or pro, (should have tried ball screw but I was afraid to crash the machine messin around). Sounds like it wouldn’t be a big deal. Ha!
Thanks for the help brothers. I hope you didn’t mind my call for help, because, I’m sure I be back.
Have a great Holliday!

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.