GRBL ERROR: Invalid gcode ID:33

Running a program that I rendered in Fusion 360 had to clean it up a bit but now I get this error. Which i don’t know what it means.

Send the file to AutoDesk so that they can fix it.

Are they implying on just rounding up your decimals?

Presumably they didn’t quite get the arc calculation correct (or maybe this is an edge case where Grbl is at fault) ---- it might be that Carbide Motion is trimming too many decimals, but I’d hope it would keep 5.

I experience the same GRBL error: Invalid gcode ID:33 when using Fusion 360. I changed smoothing on/off, changed the accuracy from 0.01 to 0.001 and 0.0001 with no effect. This only happens using the horizontal program in Fusion. I also changed the post processor back to Mach3 but keep getting the error on the same part. Does anyone find a solution for this?

Please contact w/ the details of the file in question and the settings which created it.

I’d like to see one of these Fusion 360 problem files. I’ve heard enough about this particular issue to dig into it more. Could you post the Fusion generated g-code file?

In short, Grbl follows the LinuxCNC error protocol for G2 and G3 arcs and the error checks are fairly lenient. This problem only seems to come from Fusion360 g-code programs. Not sure why, but I’m leaning toward that its’ something in Fusion360’s post processing.

1 Like

It’s not just Fusion. I got this quite frequently using VCarve Pro too. Only thing that fixed it in CM was to slightly change the depth a couple thousands deeper or lighter of the tool path.

What finally solved it was using bCNC instead of Carbide Motion. Never had the error again :slight_smile:


Here you go. Should be everything you need. (251.5 KB)

1 Like

I ran into this same issue… (spent an evening on the ipad researching)
I did this the next day and it worked.
In Fusion 360 in the post process
modify the post config file
carbide3d.cps - Generic Carbide 3d (grbl)
(for me it was line 59)
var xyzFormat = createFormat({decimals:(unit == MM ? 3 : 4)});
var xyzFormat = createFormat({decimals:(unit == MM ? 4 : 5)});

This changes the # of decimals and seems to satisfy the grbl ARC commands

I have had my xxl up and testing for 2 weeks only … Fusion 360 was loaded less than a month ago.

I did not invent this solution and I looked a too many things being new and couldn’t re-find the
creater of the solution to give credit …who ever you are thanks this worked.

Having a lot of fun with this XXL … thanks all

I see it has been awhile sense the last reply… If this is not ok to post I am happy to remove it


The simple solution is before generating the post change the unit to (mm).

I usually regenerate the tool paths the save the post file. and this error from the past for me.

I really forgot where I found the solution but I guess from shapeoko wiki.

1 Like

I’m going to 2nd what Fahad said. Forcing it to mm when saving the gcode magically makes the problem go away for me too

1 Like

Fahad, Jalapano… the fix you present is even easier that what I found…
Thanks for sharing … I will give it a test

1 Like

Thanks, I did this and it seemed to solve the problem (although I guess it could’ve been solved just by regenerating the g-code with whatever tiny variance there was in a few hours), but hopefully this changed it. This seems like a more elegant solution than simply switching to metric.