GRBL might be freezing?

Hi All. I’ve been experimenting with my SO3 for about a month now since build. I seem to be having an issue where during a program, GRBL freezes up and stops responding. I was using bCNC initially, and thought it might be due to that, so I switched over to Carbide Motion and get the same problem.

Symptom: During a program, at seemingly random spots (does not ever freeze at the same place) , my SO3 will stop responding and stop moving. I have to close out my control software and power cycle the SO3 to get back connected. If I don’t power cycle the SO3, it will not connect to any software.

bCNC says this:

while Carbide motion shows this:

I have tried: Different USB ports, different G-code Senders
Yet to try: Different USB cable

Any ideas?


Not likely to be a software problem in Grbl — more likely EMI.

The community has a lengthy wiki page on this ( ), and the standard tech support suggestion is:

  • arrange the AC cable for the router so that it doesn’t cross or be near any of the other cables
  • if you’re using a laptop, ensure that it is plugged in, preferably to a grounded outlet using a 3 prong plug if possible
  • if you’re using a USB extension cable or unpowered USB hub, please directly connect the machine directly using a shorter than 6 foot USB cable — if your cable doesn’t have a toroid (metal cylinder often molded into the end of the cable) and you have a cable which has that feature, try it
  • try a different USB port, esp. if you have the option to switch from USB3 to USB2 — if using a laptop try a powered USB hub — some laptops undervolt the USB ports to save power.
  • if your router power cable doesn’t have a toroid, try adding one (note that what seems to be a toroid on a Dewalt DWP611 is actually an anti-theft device on all the ones I’ve seen)
  • if possible, connect the router and the machine through a different circuit
  • if you have a surge protector, please connect the machine through it

Please ensure that there aren’t any extraneous wires which create ground loops.

Hopefully something in the above will work, if not, contact and we’ll help you as best we can.

Thank you for the fast response. I will look at this tonight.

I do not have my router cable running along the other cables, only crosses the homing switch wires. See the following picture:

However, this is the cabling on the other side of the machine:

It is running on a laptop, and I will try and get the permanent PC out there tonight. I am picking up a screen for it after work. If the problem comes up again, what would you attack first? I kind of want to try things one at a time to try and find the culprit.

My thoughts were:

  1. Eliminate the laptop
  2. Router powered on another outlet.
  3. Shielded USB cable

Agree those are the first things to try.

Scratch off the laptop and the router on another outlet. Fixed both those issues, still stopping in middle of cuts…

Your laptop isn’t going into sleep mode is it?

Running via desktop pc now.

If the things which are reasonable to try don’t address this, contact and we’ll sort this out.

Shielded USB made no difference. power and usb cables are routed nowhere near each other. I was running well for a while. Got a bunch of v cuts done and them bam. after shutdown and reset, went for about 15 seconds and dropped out again.

Since it’s so random, I’d wonder if there’s something else on the circuit, a heavy load such as a compressor in a refrigerator or air conditioner which is causing this.

Nothing else ruining on the circuit. It seems to really hate making circles. It always dies out when machining pockets with my 1/8 inch end mills. Last night I did 25 minutes of v cuts but when I switched to my pocketing operation it stops when it hits wood after like 5 seconds. ( I start my circular pocket and it will run for about 5-10 seconds and stop. When I re-home and re start it will make it through the previous path it made it to before stopping just fine, then when it hits wood after like 10 seconds it will drop out again.)

Performs air cuts of the program with no issues. So it is related to when the router is removing material.

I’ve opened a support email with carbide, this is the recap of what I’ve done:.

Eliminated the laptop
Installed desktop PC
Ran the router on a separate outlet than the PC and shapeoko. (Different circuit is not possible)
Routed the power and usb cables away from each other.
Suspended the router power cable from the ceiling so it no longer comes anywhere near the machine / cables.
Switched to the recommended Shielded usb cable on wiki
Ensured no other loads on the circuit interfering ( refrigerator, etc.)
Ran the shapeoko and computer on an emi filtering power strip. (APC C-25b independent emi filtering)

Control board says, “Carbide motion v2.4d”

If the difference is that it only happens when under load, then I’d suggest checking to see if the router brushes need to be changed — if not, look into adding a wire mesh Faraday cage around the plastic cap of the router.

You have run the gamut, Andrew.

What I also find of interest is that you’re running the v2.4 CM controller revision. I noticed in my go/no-go noise investigations that router RPM and cut loading does have an affect on noise levels and hiccups. You might experiment with RPM and try your pocketing cuts?

I’m running v2.2 and v2.3 CM controllers with very reliable results, including tool changing and lots of router on/off cycles with both GRBL and ESTL. I followed all the best practices for electrical noise mitigation and I have also applied ferrite cores to all my wiring harnesses.

The router is new with the machine. I got in on the deal that included the makkita router over Thanksgiving. So can’t see anything being wrong with the router.

Faraday cage sounds interesting. Any examples of them on the wiki?

I have my makkita router set at 5, I tried lowering to 4.5 but it didn’t sound like it was cutting well. It also still dropped out.

I’ve got a support ticket in. Let’s see what carbide says to do. I don’t want to accept a solution like “don’t use that rpm” as I don’t feel like that really solves the deeper issue. The feed and speed work very nice, creating good chips and getting the operation done quickly. Plus I need to have it at full speed for v cuts. They are assigning an EE to the problem.

Here is the image/post:

If it’s not on the wiki, I’ll see that it gets added now.

Just because the router is new doesn’t mean that it doesn’t need new brushes — could be a bad set, and it doesn’t take that long spinning at 5 or 10 on the dial to wear them down in CNC timeframes — the trim routers are intended for brief (by CNC standards) handheld usage.

The only other thing I can think of to try which a search of this page doesn’t reveal is a USB isolator — if you can’t find one locally I’ll suggest that we send you one if the wire mesh (and if you haven’t tried them, USB cables w/ ferrite beads) don’t work out.

That it only occurs w/ certain paths is interesting, and I believe worth mentioning to one of the electrical engineers on the team.

I added the wire mesh @DJ_Valenski noted in the above post to: — there are a few other things which you could try if you wish between now and Monday — please don’t do anything which you’re not confident you can do safely (still not wild about listing the re-wiring the router to have grounding).

After about a year of flawless running (grounded router, with mesh, running below the highest speed setting), I suddenly had a rash of stops in the middle of a job. The stops were under loading. I should have done a print screen, it wasn’t loss of comm with the GRBL, some other error. I can propose two possibilities:

  1. The 1/4 flat end bit is getting dull???
  2. I was cutting 2" ellipses out of a 3/4" Poplar board. I made the ellipses but making a large ellipse in Sketchup, screenshot to jpeg, then hand trace in detail for a very close to perfect oval. Made a lot of line segments. Is it possible that it could overload the GRBL somehow? It cuts the first oval okay, sometimes the second, but stopped halfway through the 2nd or 3rd oval. I was taking 0.1" deep passes.

Any thoughts? Someday I would like to get the latest version of the GRBL board for my standard S3.

Oh, I might also add that I recently upgraded the exhaust system to how it looks in this picture. Maybe I should ground that spiral wire in the hose?

Check to see if your brushes need to be replaced? Agree that you should ground the hose.

That should be the only change to the machine due to electronic wear — the stepper drivers aren’t supposed to wear out, the balance of the machine, V-wheels will wear (better them than rails), belts will stretch or break, and that ought to be it.

Okay, software errors — unfortunately, there’s no positional feedback or spindle information (unless you have a SuperPID/VFID?), so dullness shouldn’t matter. It could be a 33 error if you’re sending arc information which Grbl doesn’t agree on. Further details of the CAD/CAM?

Post the G-code?

Brushes? only a maybe.
I think steppers, belts, and wheels are okay.
I might have 20-30 hours of total runtime.
I used Carbide Create and Carbide Motion only. (latest downloads)
I can send the G-Code later if you are really interested.