GRBL Panel Training (Video)

(Adam X) #1

As promised, here’s a video on running GRBL-Panel with a Shapeoko 3 XXL (or any S3, really).
It’s quite long winded, I do love the sound of my own voice:

grbl panel can be downloaded here:

It’s quite a rough take with quite a bit assumed and glossed over, let me know if you’ve got questions. I hope this helps somebody!


Grbl Panel HowTo Poll

Well done, Adam. It’s such a nice program. Perhaps more will start using it.

1 Like

(Griff ) #3

Thank you, sir. You’ve opened a door for me, will be digging deeper.

1 Like

(ted brantley) #4

I’ve been wanting to try GRBL Panel for a while now. Thanks for the helpful video. I just downloaded the software. :slight_smile:

1 Like

(Griff ) #5

Adam, should I use a different post in F360 for grbl panel? I’ve tried a few files that worked fine in CM but cause red spindle errors in Panel. My spindle is manually controlled.


(Adam X) #6

I’m rusty on F360… what post processors are listed there? Is there a generic grbl post?
What lines/errors are you seeing? Toss up a screen shot… and post the gcode, I’ll take a look.


(Griff ) #7

Hmmm, I’ll have to send the gcode from my computer.


(Adam X) #8

Gah, that’s a really angry application error. Just to be sure it’s the app and not gcode, try running an airjob on the attached file (it’s a small 6x5" dust boot) (149.4 KB)


(Griff ) #9

Hmmm, works fine. Should I try another post I guess?


(Adam X) #10

Attach the gcode that’s crashing grbl panel, now I really want to try it :slight_smile:


(Griff ) #11

Is this what the end screen should look like. I’m guessing not.


(Griff ) #12

heres the file
tray 4 (22.6 KB)


(Adam X) #13

WHOA, yea, crashed my panel too. I just did a debug and it looks like a bug in grbl-panel not wanting to accept tool changes with three digit numbers! Try switching your tool number in F360 to a two digit value. I just updated your gcode with it and tested and it runs now.

Attached for you to try…tray 4 (22.6 KB)

1 Like

(Adam X) #14

New release of this software this afternoon, several big improvements:

@Griff I raised your problem as a bug to the dev and it’s been addressed in today’s release


(Griff ) #15

Sweet, thanks. I’ve renumbered all my tools, ha ha. I was fighting through a fusion reinstall yesterday, very frustrating.
All’s good now. I’ll try out the update.


(Adam X) #16

Keep in mind, as pointed out to me by the grblpanel dev, it’s GRBL that doesn’t like three-digit tool numbers, not just this gcode sender. I believe there is a Carbide3D post-processor available for F360 which should know these things…

1 Like

(Griff ) #17

The C3D post for Fusion was giving me arc errors in CM410.
I’m now using f360-easel.cps for my Fusion post. So far so good.

1 Like