Gsender and prob

I am looking at Gsender 1.1.4 and it look kind of nice, I really like the view as the work is being done. I have come up with a problem.

When I set the xyz zeros with the prob, after it is finished the Z goes all the way to the top and hits the mount. Then when I check it, it is about 1/4 inch lower then it should.

If I just set the Z with the prob it is fine. When finished the Z goes up to the top just when it is homed. When I check the Z 0 it is spot on.

I am not sure what I am doing wrong.

Thanks for any help.

Are you using a macro to probe? Can you share your XYZ probe macro or settings?

GSender has settings for an XYZ probe. You can’t just use any probe without adding those dimensions to the settings. Also, gSender doesn’t use a “lip” like the C3D probe uses. I turn my C3D probe upside down (after entering its dimensions) to do my Z-zero.

If your router goes all the way to the top, it usually has something to do with the Safe Zero value. When it hits the top, it will lose steps. That’s why your Z-zero will be off.

I am not using a macro, I just have it set up in the settings. It works fine for XY and it will work fine for Z only but not all 3 at once.

What probe are you using? What are your probe settings?

i did put all the dimensions in settings. The prob works fine for XY by itself but if I do the XYZ that is when it screws up.
I am setting the prob on the edge with the 2 lips on the corner and it sets XY just right.
If I set the prob on the edge just like setting the XY and only do a Z 0 it will work fine.

Now I have to find out why it hit the top when I do an XYZ.

The Carbide first prob and all the dimensions have been set in Gsender.

It’s raising to the top after the prune sequence? What’s your retract height setting?

I am not sure, I did’t find a place to change it. What is funny it works fine when I just do the Z zero.

Bill repeating that it works with z only will not help find out what is going on. Several people have asked you specific questions. They cannot help you unless you give them specific answers. We have a lot of talent on the forum but they need data to help you. Please respond with the asked for data and you will get help. With no specific data they would be shooting in the dark.

I don’t know what more data I can give.
The prob settings are: Z Thickness .867, XY Thickness .278, Length 2.363, Width 2.363.
I am not using a Macro.
The C3D prob works fine, if it is set on the edge (lips touching the side and front) the thickness is the same for the Z as turning it over.
I would love to give the retract height, but I cannot find that setting.

I just don’t know what more data I can give.

Settings (gear icon) → Probe

It should be the same for any probe with the built-in probe settings anyway. Next time you probe, can you copy paste the console output? I don’t use the probe routines.
What probe are you using?

I am using the older C3D prob, square block with the 2 edges for X and Y.

Here is the prob settings.

This is the code for Z only.
[PRB:-347.725,-313.475,-13.265:1]
ok
feeder G4 P0.3
ok
feeder G10 L20 P1 Z0.867
ok
feeder G91
ok
feeder G0 Z0.15
ok
feeder G90
ok
feeder G20
ok

This is the code for ZXY
PRB:-347.700,-328.150,-24.530:1]
ok
feeder G4 P0.3
ok
feeder G91
ok
feeder G10 L20 P1 Y-0.403
ok
feeder G0 Y-0.15
ok
feeder G0 Z1.317
ok
feeder G0 Y0.728
ok
feeder G90
ok
feeder G20
ok

I hope this is what you needed.

What’s your $13 value?

It is disabled, that is the default for Shapeoko.

I did enable $20 at one point (Soft Limits) and it just gave me an error after it checked X, and stopped.

On the XYZ, can you get the log before the PRB line?

This is after I homed it. I can give you the Homing code if you want it.
ok
client $H
ok
client $J=G20G91 X-1250 Y-1250 F118.11
ok
client \x85
feeder G10 L20 P1 X0 Y0 Z0
ok
feeder G91 G20
ok
feeder G38.2 Z-1.2 F5.9
[PRB:-288.300,-288.300,-17.090:1]
ok
feeder G91
ok
feeder G0 Z0.15
ok
feeder G38.2 Z-1.2 F2.95
[PRB:-288.300,-288.300,-17.080:1]
ok
feeder G10 L20 P1 Z0.867
ok
feeder G91
ok
feeder G0 Z0.15
ok
feeder G0 X-0.797
ok
feeder G0 Z-0.591
ok
feeder G38.2 X2 F5.9
[PRB:-299.750,-288.300,-28.330:1]
ok
feeder G91
ok
feeder G0 X-0.15
ok
feeder G38.2 X2 F2.95
[PRB:-300.225,-288.300,-28.330:1]
ok
feeder G4 P0.3
ok
feeder G91
ok
feeder G10 L20 P1 X-0.403
ok
feeder G0 X-0.3
ok
feeder G0 Y-0.797
ok
feeder G0 X0.797
ok
feeder G38.2 Y2 F5.9
[PRB:-287.425,-297.525,-28.330:1]
ok
feeder G91
ok
feeder G0 Y-0.15
ok
feeder G38.2 Y2 F2.95
[PRB:-287.425,-297.350,-28.330:1]
ok
feeder G4 P0.3
ok
feeder G91
ok
feeder G10 L20 P1 Y-0.403
ok
feeder G0 Y-0.15
ok
feeder G0 Z1.317
ok
feeder G0 Y0.728
ok
feeder G90
ok

I think this is the issue. I don’t know where this 1.317 comes from. Edit…I think I do now. On other forum.
How thick is your stock?

I don’t believe you ever said what you are using to design the parts (generate the gcode.) C3D, Vcarve or something else?

The stock is .748.
I guess I will just have to do a work around.

Thanks