Help! I'm STUCK - literally

Hi all,

I am new to my Shapeoko XL cnc machine, which was previously built by someone else before I purchased it off of them. I have run several successful carvings - up until now. I have NEVER had these issues before, and the machine has always behaved. Now I’m dead in the water.

I wanted to create a square on my waste board to outline the boundaries of what I was about to cut, which is a 19x12 piece of hardwood. So I created a square carving pattern in carbide create, size 21x14. I loaded it into Carbide Motion, hit center, zeroed the x,y,and z , then ran the program. Everything was going fine until it started cutting towards the top of the machine, and it hit its y axis limit. Still not sure how that happened, but it started grinding, with the bit slightly in the wood. I hit the pause buttom, and the bit started going DOWN into the wood further! I turned the machine off with the kill switch. I turned on the machine again, and went to initialize it, and it started moving down again! I shut it off again.

So here I am, stuck with my 1/8 end mill in my waste board, and every time I try to initialize the machine, it buries the bit further in. I am wondering if triggering the y axis limit switch did this? Or if something is stuck?

So now I need to get the bit out of the waste board by raising it out, but can’t with Carbide Motion without initializing the machine, which drives the bit further in.

Thank you in advance!


Hi @nmkiriazis,

let’s get the cutter out of there first. With power turned off, are you able to manually turn the leadscrew with your fingers? (assuming you have a Z-plus or HDZ? With a belt-driven z you should just be able to pull it up manually)

if not, you could do this to pull up the router:

  • power on the machine, connect to cutter, but do NOT “initialize machine”
  • go to the MDI tab, and send those commands in that order:

$X (and “SEND”)
G21 (and “SEND”)
G91G0Z1 (and “SEND”)

This should move the Z axis up 1 mm (just tested it on my machine), regardless of the initial state or faulty switches (since the $X line allows to bypass homing). You can repeat sending the G91G0Z1 command as many times as needed to retract enough to pull off the cutter from the cut

In any case, you can also contact


With the machine powered off try loosening the collet. This assumes you have access to the collet which may not be the case if you have a dust shoe installed. If the bit is physically jammed in the wood this would allow the router to move under control of the motors.



This got it out!! Thank you so much!

Now I need to figure out why it happened in the first place…do you have any thoughts?


Details of how your machine is setup would be helpful, ie: how is it hooked up to the computer, any grounding, isolation or chokes added.

1 Like

I’m sure this would be extremely helpful, but the machine was set up entirely by the previous owner. All of those types of details are completely lost on me, unfortunately. I have a ton to learn about the back end, including the design and setup. All of my work on the machine has been carving and design, with next to nothing around the machine itself.

Please review the assembly instructions for the machine version you have:

1 Like

You and Julien have been invaluable! Thank you for your incredible support.

1 Like

The “hitting the Y axis limit” may just be the result of what the dimension of your piece was, how it was positioned on the wasteboard, and where zero was set. The XL’s work area is 16" along Y, but part of that usable area is at the front of the machine (which can be very useful at times, with a vertical workholding jig). So your a left with about 14" inches of Y travel inside the machine, and it was then likely that your 21"x14" job hit the limit.

Now the bit going further down into the wood upon hitting the Pause button, that’s weird. Upon pause, normally the controller stops movement, retracts slowly, and then retracts faster until the router is parked at the top of the Z axis. Could it have been the endmill slipping in the router collet? (upcut endmills tend to be pulled into the stock, due to their geometry)

Did you have a chance to run another job since then and does the machine behave as expected now ?


Here is what ended up solving the problem.

I was able to remove the bit with your MDI suggestion. I was working separately with Will, who suggested once it was out, to do an unplug and replug with the limit switches. I pulled the panel off, did as he suggested, and it went to the top right corner as it was supposed to. It then gave me a warning of “GRBL Error: Homing failed, pull off didn’t clear”, and then “homing cycle failed”. I shut the entire system down again, rebooted, and tried to initialize again. It worked, and has been carving away.

Thank you again for all your help! Case closed.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.