Help Please, My machine is leaving marks on my projects!

I need some help. I have been trying to work some lines that my Shapeoko Pro is leaving behind. I have reduced Stepover as low as 5%. Worked with my Feeds and Speeds you name it I have tried it. Yet I continue to see these lines after the work is complete. The pictured attached is a 3d relief

The Latest Geometry and feeds and speeds are as follows.

Roughing 1/4 Endmill
18000 Speed
.125 Pass D
30% Stepover
Feed 80
Plunge 40

Amana #46286 Tapered Ballnose 1/8
5% Stepover
90 Feed
40 Plunge

Someone told me it could be my Tram. Any advise onto what could possibly be wrong with it.
The machine runs and moves like it suppose to, so I dont know what could possibly be wrong with it.

Attached are 3 pics ran at different feeds and speeds and stepover with the same results.
Any help would be greatly appreciated.

Thank You Retired Veteran trying not to loose my mind over this machine!
Eagle Pic 1
Eagle Pic 2
Eagle Pic 3

Please post the .c2d file, eithere here, or to

I’m seeing 3 different results, just all with witness marks.
#1 has concentric circles around the center of the part
#2 has concentric circles, with the centers outside of the part, and only on the outer edges
#3 has nearly parallel marks across the whole part.

This would indicate that it’s not a problem with the model, but with the toolpaths or the mechanics of the machine.
Were the 3 tests performed with the same type of toolpath? Same cut pattern?
Your images are too small for these old eyes to read. Is there a tolerance setting? (Is that Vectric?)

Thank You for your reply. Yes I tried different ways of cutting it some raster some offset. With the same result. Yes I did use vetric. The model came directly from the vetric clipart. I am using the real version of vetric not the bootleg version… I cut some projects prior with no problem and lately its consistent with these lines. These are only a few pictures of the jobs I have done and all have these same marks.

Tod thank you for your assistance.

I have tried many different toolpaths and its the same thing.

You mentioned mechanics of the machine, Any idea what could be the problem.

Could it be Tram like someone suggested it could be?

Best way to check the machine mechanically is to install a 1/4" probing pin and then power up the machine so as to lock the motors and grab the tip of it and trying to push/pull — it should not move — investigate each aspect of the machine which allows the tip to move and address it.

Does it have to be a probing pin?

Could I use an endmill in its place, since I dont have a probing pin?

Use gloves or soft-jawed pliers.

Or just buy a 1/4" aluminum dowel from the hardware store and cut it off.

Tools are sharp. A little trickier to pull/push on without injury :wink:

Tram should not make a difference with this particular issue. Only if you are cutting flat surfaces with a flat endmill, or using several tools with different tool lengths.

If you want to share the toolpaths (G-Code), I can simulate them in a higher resolution to see if the witness marks are apparent in the toolpath.

1 Like

I use Vectric and have the same model.
I just simulated the cut and it is fine.
My money is on a machine issue.


I use vetric as well, amd from what i can tell set up my 3D files the same as you, with the same bits, specifically the 3.6 deg tapered ball nose finishing pass. In my experience the raster cut with 0 or 45degree works good also if i am wanting super clean i will run another finish pass at -45degree to hvae the bit pass another direction. When this has been happened to me i have had to verify belt tension and most importantly found my eccentric nuts on the z axis slipping and worn to where i replaced them. After doing those 2 things i have had no issues. Hope this helps.

I looked at my machine it is different i regards to the ease truck nuts and bolts. It doesn’t have those nuts and bolts. Not unless I’m missing something.

I have the Shapeoko Pro XXL

Thanks for the feedback!

I meant to say eccentric nuts

1 Like

I see yeah the pro has linear rails so my next thing would still be the belts. Lots of info on here about belt tensions as well as making indicator marks on your motor to verify slippage. Even though I have a different machine I still feel as something is slipping and that is causing the marks based on you saying you verified stepover and have a level cutting surface.

Also check that the setscrews holding the pulleys on the stepper motor shafts are tight and that one setscrew is on the flat of the stepper shaft. It’s not unknown for them to work loose and slip, especially under load. Check them all, but definitely check the z-axis ones.


Still struggling with the lines on my projects.
I notice that My cnc is tilted. Meaning the front sits about 1/2 higher than the back of the machine. Could this be the cause of the lines on my projects. I have checked every screw and the machine runs perfectly. I checked the Tram and it all lines up. I believe the table workbench that it sits on is sitting higher in the front than the back. Your thoughts?

New to the CNC business anyway you can take a picture of the setscrews you are talking about.

thank you greatly appreciated

Precision has to start somewhere.

Best and most straight-forward thing to do is to begin by leveling the table the machine is sitting on, then continue working from large → small:

  • make sure the Y-axis rails are level and parallel w/ each other and plumb
  • ensure that the X-axis gantry is level and at right angles to the Y-axis rails and plumb
  • ensure that the Z-axis carriage and carriage spindle plate are level and plumb

I have the 5 Pro, so it’s a little different, but look at the Z-motor (and the other motors). On the motor shaft, the shaft enters a coupler on my machine, or a pulley on some belt-driven machines. The coupler or pulley has a couple of setscrews holding it onto the shaft. They sometimes work loose, giving z-axis slip or jitter. If it’s a coupler, there are a pair of setscrews both ends.

1 Like