Help with Rapid Z, Plunge, and Home/Start Position in VCarve Pro

Hello! I recently bought a XXL and have been doing some smaller projects with mostly success. The problem I am currently running into is figuring out my Z1 (Clearance), Z2 (Plunge), and Home/Start position areas with VCarve Pro 9.5. I’m pretty sure I understand what each one does, it’s just how they work together that is puzzling me. I just purchased some larger hold down clamps that require at least 1.75" of Z clearance and when I put that into the Z1 for clearance, the program automatically populates my “Z gap above material” with that number plus 0.01". So if I enter 1.75" in Z1, 1.76" gets put into “Z gap above material” and throws off the cutting depths. After I zero and press start, the machine will retract and hit the upper limit switch, then plunge WAY deeper than what I set it at for flat depth. Seems no matter what I do, they are related to each other and I can’t change one without affecting the other.

My ultimate goal is to be able to set a safe Z height (Rapid Z gap) that will clear my clamps and be able to adjust my Z gap above material independently. Is that something that the XXL is capable of? Have any of you ran into this problem?

Specs: Machine- Shapeoko XXL
Software- Vcarve Pro 9.5

Do you have 1.75" of Z above your work zero? When you run your Z into the top of its range, it “thinks” it is higher than it is. That’s what causes the deep plunge. If your controller thinks the Z is at 1.75", but it’s actually only 1.5", when you plunge to -0.125" you’ll actually go to -0.375".

The SO3 is capable, but it will just do what you tell it to do.


Yes, my work piece is only about 13/16" thick (.8125") so I have room. That makes sense. Do you know how to independently adjust Z1 clearance and Home/Start position in Vcarve Pro?

This all depends on where you are setting zero. Is zero set at the wasteboard (bottom of stock), or the top of stock?

Zero is set at the top of my stock.

This sounds a lot like you are using the zero at the top of the stock, but the file is set up for bottom of stock.

1.75" is a lot of clamp over that material … you’re telling the machine you need 1.75+" over the zero to accomodate the clamp - but you also said above that the clamps were 1.75" tall…which is fine to input if your zero is on the wasteboard, but wrong if zero is on top of the stock.

This isn’t really a “XXL capable” question, this is a software issue, vcarve is responsible for managing this. That said, @neilferreri above might be in a better place to answer this, as I have only used vcarve a couple times and I’m sure he knows it better.

The way this works in -most- software is you set a height from the wasteboard (bottom of stock) for clearance/fixture , and a different height from the top of the stock for rapid (that can sometimes be further refined to be lower if the material in the way has already been removed).

Well said, Thank you! When you put it that way, it does sound like there is a lot of Z clearance. I’ll have to double check my settings, I know it’s something that I am screwing up and haven’t learned yet. I’m a noob!

If your retract height is outside the working envelope of your physical Z the Z will move up, hit the top of the carriage, skip steps or slip the belt and “think” it’s in the correct place, then plunge and destroy your material or break a bit or both. Ask me how I know this :wink:

Ensure your Z isn’t retracting beyond what is physically possible. Set your zeros as if you’re going to run a job, then remove your material and try an air cut. If the retract height causes the machine to go high enough to hit the physical limit, then you know what’s going on. One way to get around this is by moving the router up in the router mount. 1.75" is a huge retract height when you only have 3" of physical movement.



The start position is literally just where the the machine will go to start the program. It wouldn’t make sense to start below your clearance height.
When your end mill is touching the top of your stock, what’s your machine position? Or measure the space to your Z limit switch.
@mikep, I’ve only played with V-carve a couple times. I think I’m in a minority that finds it to be unintuitive. I prefer Fusion or similar. I need to give V carve more of a chance.

1 Like

That’s exactly what happened! I heard the machine hit the upper Z limit and skip for a bit, then plunge way too deep. Now that I think about it, 1.75" is a lot of retract. I did some practicing last night and played around with Z1, Z2, and home/start position and learned a good bit.

I will certainly take your advice and run and air program, especially when I cut for customers! Thank you!

Yea, you’d think it would hit the homing switch and know it made a mistake, but it’s a “homing” switch, not a “limit” switch. I know there’s a way to configure Grbl for limit switches, but I’ve never messed with it. Glad you found the culprit!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.