HELP. X-axis grinding stuck motionless

New owner here. Thought I had everything put together but I’m having an issue that’s grinding on me. Ha.

I installed Motion 4 and everything connected fine. It tries to run a homing cycle before it will let me use the jog feature. The Z axis tests up and down, then the gantry moves to the back of the machine. It’s touching the end plate, and I can watch the homing switch being pressed. But it just sits there for a second, then the Y motors grind in place for a minute, then give up and I get an error in Motion.

I checked to see all the wires are connected to the right places and there’s no obvious damage anywhere. Connections look right.

I scrapped Motion 4 and installed 3 instead. Now I can use the jog feature to move the Z axis and Y axis without issue.

But…the X axis won’t move. It seems stuck in position and the motor is angrily trying to break free. It’s almost shaking in one spot. It will keep this fight until I jog the X in the opposite direction. It’s not a one direction problem either - if I start by going left it will fight and grind until I click once to the right, and vice versa.

I tried loosening the X carriage wheels to be sure they weren’t too tight (to the point of having some slop). Didn’t help. I tried loosening the X belt to be sure that wasn’t too tight. Same problem. Tightened the belt. No better.

What else do I try? It’s trying to move but seems stuck. I can see the pulley turning back and forth against the belt as I try to jog the machine.


First, don’t use CM3 with Grbl 1.1 — it can cause weird problems — if you wish to use the machine w/o homing reflash to Grbl 0.9: GRBL 1.1 and Carbide Motion 4

I’d suggest going back to CM4, resending the defaults: and resolving the homing — we have a basic page on that here:

Check to make sure that the X-axis wiring is correct/consistent with the other wires.

Make sure that the machine isn’t getting hung up mechanically.

If none of the above addresses the problem check in with and we’ll do our best to help you sort this out.

1 Like

Ok, I went back to CM4. What do you mean by “resending the defaults”? I’m very new to this.

The wiring harness for the X was the tiniest bit askew on the control board so I disconnected and reconnected. The harness by the motor was fine, but I disconnected/reconnected that one too.

What else could be getting hung up? It’s not catching on the drag chain. The V wheels are snug but turning. I even tried loosening the rollers below the motor pulley.

I made this video to show the behavior:


I had the idea to switch out the Z and X leads and send commands through MDI. And the X travels just fine. So it’s the wiring.

The cable itself doesn’t show any issues, so I started looking at the harnesses. The X harness at the motor has the wires ordered Green, Black, White, Red. Every other harness at the motors is wired B, G, W, R. So I think I found my issue.

The instructions for re-sending the defaults are at the link:

The noise pretty definitely indicates a wiring problem (it’s almost never the motors, if it is, it’s usually their wires).

Check thing by swapping connections around:

  • Power down
  • Connect X-axis motor (unknown if good or bad) to Z-axis wiring extension (known good) to Z-axis stepper driver (known good)
  • Connect Z-axis motor (known good) to X-axis wiring extension (unknown if good or bad) to X-axis stepper driver (unknown if good or bad)
  • Connect and test the machine by jogging — if the problem switches to the other motor we know the motors are good, and the problem is in either the wiring extension or stepper driver.

If the X-axis motor tests good

  • Power down
  • Connect X-axis motor (tested good) to Z-axis wiring extension (known good) to X-axis stepper driver (unknown if good or bad)
  • Connect Z-axis motor (known good) to X-axis wiring extension (unknown if good or bad) to Z-axis stepper driver (known good)

Let us know which part(s) are bad at and we’ll do our best to help you sort this out.

I figured it out. The wires were put into the harness incorrectly at the motor end of the X cable. I popped them out, switched, and now it’s running.

Thanks for the help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.