HELP - Z Axis Calibration

I upgraded the spindle bracket on my S03 to give it added rigidity when machining aluminum and garolite XX. I’m not sure if it’s the added weight on the Z-Plate or the fact that I made the belt much tighter. But now the stepper calibration is off.

The nominal depth of the slot on this part is 5.338mm and it’s measuring at 7.67mm.

Let me know if my math is wrong, but from my understanding…

5.338 / 7.67 = .696

40 x .696 = 27.838

So in Carbide Motion MDI I should type in $102=27.838

But my issues is when I type that in and hit send, the offset doesn’t change and the $102 value just stays at 40. The output is this:

(797): <- ok
(796): <- [GC:G0 G54 G17 G21 G90 G94 M5 M9 M56 T0 F4000 S0]
(795): -> $G
(794): -> gc_parser_state
(793): <- ok
(792): <- [PRB:0.000,0.000,0.000:0]
(791): <- [TLO:0.000]
(790): <- [G92:0.000,0.000,0.000]
(789): <- [G30:0.000,0.000,0.000]
(788): <- [G28:0.000,0.000,0.000]
(787): <- [G59:0.000,0.000,0.000]
(786): <- [G58:0.000,0.000,0.000]
(785): <- [G57:0.000,0.000,0.000]
(784): <- [G56:0.000,0.000,0.000]
(783): <- [G55:0.000,0.000,0.000]
(782): <- [G54:0.000,0.000,0.000]
(781): -> $#
(780): -> gc_get_offsets
(779): <- <Idle|MPos:-5.000,-5.000,-7.184|Bf:14,128|FS:0,0>
(778): -> gc_sync
(777): <- ok
(776): -> $102=27.838
(775): -> gc_not_motion

This is my grbl version and CM version:

EDIT: One more thing to mention that is really strange. Is I have a digital indicator and when I mount it to the Z plate and jog the z plate down 1mm the indicator reads 0.95mm. Which makes me wonder if the issue is in the program?

***Another thought, I have used UGS and PicSender for the Jtech Photonics laser I have. I wonder if the settings from one program for grbl interferes with the others? I use PicSender for the laser. And there have been times when the CNC acted weird and I just found out if I would go back into CM and hit send config that it would fix itself.

Would it be optimal at this point to just reflash the firmware to standard grbl1.1 and get rid of PicSender and UGS and just restart from scratch?

Your help is appreciated, because I have 13 customer orders to fulfill which is around $8,000 in business for me and it’s halted because of this issue.

This is my website for those that are curious.


So after some expirmentation I realized that when I was writing the $102 code it actually was making the adjustment, but then when doing the send config data in CM it just always showed 40 no matter what. Is this a CM issue or a glitch with my grbl1.1f ?

I input this:
/$102=41 and it seemed to be a lot better. My math before was wrong I think. But now a 1mm jog in CM shows a 0.99mm movement on the digital indicator and I believe that cheap indicator is only accurate to 0.01mm so thats close enough for me for now to keep running.

Any of you pros have an opinion on this?


Whilst the $ commands should work in CM I don’t find they always do.

I now use UGCS where there is a a machine settings box and you can change all the $ really quickly.

1 Like

Interference from using another program and then switching to Carbide Motion is possible — we recommend re-sending the defaults for CM4 (and then updating any machine-specific settings/calibrations).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.