Help1 z axis problem

Dear all,

I purchased my shapeoko 3, tried it out with spme basic text 3 mm depth cut and it worked like charm. Then…
I tried with a little bigger cut thay was supposed to stard by carving three 6mm holes (far 10 cm crom each other on the x axis) with a 6mm bit. The first hole went good, the second one was half deep, for the third hole the bit didnt even get close to the wood. I tried with another endmill all the way in (so not a matter of loose endmill) and i got the same.

Then went back to the carved text gcode I used for testing, set all zeroes (i always set zeroes so that also is not the problem), run, and the bit doesnt even lift up to move but starts scratching the wood.

A few notes, I have set the retract height, and the same gcode file was working fine the first time.
When I jog the machine with motion manually they work perfectly, and when the power is off i can move ot smoothly in all directions as when I built it.

When it finishes the cut (even though not correctly) the z carriage goes up and i can hear that the motor would like to go higher that it can, so it doesnt stop at the proper height…as if it thinks the router is in a lower position.

Sorry for my english, i hope i can fix it asap

Please check the machine mechanically ( ):

​ It is also important to be sure that the collet is correctly tightened, the endmill fits correctly and doesn’t slip, and the router is mounted securely in the mount, and that the mount doesn’t shift.

Also feeds and speeds may be a consideration: and see for concepts on this and for a testing technique

Beyond that it’s usually a matter of ​Calibration and Squaring the Machine c.f.,


Do you actually have a 6mm collet that you’re using with that 6mm end mill? The Dewalt collet is 1/4”, 1/4” is actually 6.35mm, it will never correctly hold a 6mm end mill, it may look ok, but it’ll slip. The other thing is how low do you have the router mounted in the mount? The sound at the retract you’re describing sounds to me like the machine is trying to retract higher than the actual Z axis travel envelope, 80mm from memory. The homing switch will not limit how high the machine retracts, but usually that causes a deeper than expected plunge.



I live in europe, so I had to get the european version of the Makita, which comes with 6mm and 8mm collets. Infact I couldnt use the endmill provided with the shapeoko yet. The makita is all the way down, as far as it could go. I am really frustrated, later I will do a few more tests and post an update

1 Like

Ahh ok, hadn’t considered the EU version of the router with metric collets.


My guess would be that the Z axis did not like the plunge you programmed to do 6mm holes using a 6mm endmill. Which by the way is difficult to do: did you use Carbide Create or Fusion360? what kind of toolpath and what plunge rate ? Endmills are notoriously bad at drilling holes, chip clearing is a problem, so plunging too fast can put enormous force on the Z

Anyway a possible problem is that during this first run, the set screw of the Z axis became loose due to the excessive force while drilling. And now that it is loose, Z commands to the motor do not translate to the proper Z movements as the pulley is slipping.

The very first check as Will said would be to check this set screw, check Z belt tension too.

If your machine still homes correctly I assume the Z limit switch is still OK.


While I think it is probably due to a Z axis issue like the belt not being tight, another possible issue could be the use of an endmill that is not up cut, the endmill cannot clear the chips out of the hole so the endmill cannot get to the bottom and the Shapeoko is not powerfull enough to push it through. It is also pretty risky to cut a hole the same diameter as an endmill, some people have reported setting fire to their wasteboard. as the chips cannot be cleared out properly and the friction overheats the wood and set it on fire.


Thanks everybody. I figured that the issue was indeed that I waa trying to drill a hole with the same diameter as the end mill. I had to tighten again one of the screws of the spindle holder, it probably went loose when trying to drill.

So I think its fixed now. I have two final question: what actually happened to the machine? I mean when it tried to drill and it wasnt powerful enough, so it had an wrong offset in the z axis (proved by the fact that it was trying to retract beyond the z axis limit switch). When this happenes, is it kinda misaligned with carbide motion? How do I reset this misalignment?

Bonus question, is there a way to drill? I red that i must use a smaller bit that the hole, but is it going to work if I get some kind of drill bit?

Thanks a lot to everybody

1 Like

what happened: due to excessive force on the Z axis, the motor must have skipped steps, and/or the pulley must have slipped on the shaft. After that, the real mechanical position is not the same as what the controller think it is (so yeah, “Carbide Motion is not synced” with the real position of the machine anymore, that’s one way to see it)

If you tighten everything and home the machine again, this should “reset” this effect, as hitting the limit switches tells the controller where it the machine actually is (for real)

To drill, indeed in the beginning you should use an endmill smaller than the diameter of the hole you need, and do a pocket toolpath. Later, you can learn to use peck drilling toolpaths (not available in Carbide Create) or even indeed use actual drill bits, but keep that for later I think.


One last thing though…

In order cut small holes,with endmills smaller than the holes themselves, it would be convenient for me to have a 1/8" collet (3,175mm) for my Makita RT0700C. Considering the fact that I am in Europe (Italy), do you guys know where I can find an adapter without having to ship a tiny piece of metal from the other side of the world?
I found on italian Amazon the makita 1/4" collet adapter an I should receive it tomorrow.
So also a solution like the one carbide3D offers (1/8" inside a 1/4") would be good.
I researched but I couldn’t find a solution…any idea? (even though most of you probably live in the land of inches and miles)

I bought a 6mm to 3.175mm adapter, and then used the 6mm Makita collet.
(and later, bit the bullet and bought high-precision 3.175mm collets for the Makita from Elaire in the US)

Adapter are not great due to presumably increasing runout, but in all honesty my tiny/cheap adapter has served me perfectly to use my 1/8" endmills over the last two years for everything except metal work.

It does not have to come from the other side of the world, here’s a quick search on Italian eBay, cheap enough and ships from Germany:

1 Like

just to illustrate, here’s a quick snap of my collets:

From left to right:

  • 6.35mm Makita collet (amazon/ebay)
  • 6mm Makita collet (supplied with the router) with the 6 to 3.175mm adapter
  • 3.175mm cheap-o collet, unbranded (and not suitable)
  • 6.35mm precision collet from Elaire
  • 3.175mm precision collet from Elaire

The one you want right now is probably the second one (less than 10 euros shipped for the adapter)


Now I see, I’ve just ordered the one you suggested from e-bay.
I will follow your path, practice with these ones and then get some from Elaire.
Your picture shows the difference in quality.

Now, maybe I should open another topic but, this might be related to my previous error of trying to drill.

I finally was getting the hang of it, did my first complete cut on soft wood…then I was going to do another cut when, while jogging by 1mm to reach the Z zero…pluck! The Z belt broke…I think maybe my previous errors put some extra tension on it…!?

Anyway, just to make sure, I found this replacement on Amazon. It should be the right one, if someone happens to confirm it I’d be very happy :wink:

Sorry for this bunch of newbie questions, but I’m a newbie

It looks like it’s the right specs. The wiki says:

"Z-axis on SO3 uses 6mm wide 520 or 524mm endless loop "
and also that it’s GT2, so 2mm pitch


I will note that the Gates branded belts I’ve bought from SDP/SI (BB Man. ought to have the same) seem to be better quality than unbranded belts of unknown (presumably Chinese) provenance.

1 Like

Hey Julien, would you know the SIZE of the Allen Wrench needed for the set screws in those Nema motor shafts. Mine seem tight, however, a set screw to really check would be handy. I just held the pulley with my fingers and pushed the “Z” up and down to check mine, which seemed tight.

1.5mm (see

I honestly did not know that before I checked, I just grabbed all small allen keys I had and tried until I found the right one. And then my set screws were SO tight that it took me forever to remove them when I upgraded to the HDZ :slight_smile:

1 Like

Thanks, Julien, nothing I had fit to really check out the tightness of the set screws.
They come in multiples per pack for around $4, but it was an $8 delivery fee.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.