Holy cow I'm getting frustrated

HELP ME!!!. Ok so I’m working on a project, and the first cut is a .125 pocket with a .25 endmill. I checked, double checked, and triple checked the settings. Start is at 0 on top of board, stock size is set correctly. Machine is zeroed out correctly on top of board. I run the toolpath, and instead of cutting at .125 it does all the way down to almost .500. Here is a sample of the code it is Shapeoko (inch) post processor using Vcarve pro. Looking at it everything seems correct. the (G1Z-0.125.F50.0) command is the depth of the cut correct? Why is the machine doing this? tried the GRBL (Inch) processor too, and same thing. Any ideas. First time this has happened to me .


How much room do you have above your stock? Any chance you’re not getting all the way up to your 1.01" retract height?


I’m being a little pedantic here, but I also think it’s important.

IF the machine is in absolute mode, it means move to Z=-.125"
IF the machine is in incremental mode, it means move BY -.125"

Because there’s no G90 you can’t tell for sure from this if the machine is in either mode, and depending on where you start the program, you might not be able to tell (for example, if you start from home, it might look ok - if you start from some random x/y, it’ll go zooming off away from where you set work zero instead of to it)

Of course, none of this explains why it would be 4 times lower than expected, so it’s not exactly helpful to the problem at hand.

Neil’s question is a great one though, if there’s not an inch+ (1.01") of travel above the material, you’ll lose some steps when it moves up, and then move down “too far.”

1 Like

Check the set screws on your Z pulley and ensure your belt is tight. I’d say when it moves up for the tool change, it’s not moving all the way due to slippage. Wouldn’t be hard to be out .375 if it’s doing that.

1 Like

From the answer posted to Facebook:

In Vectric Vcarve 9, I believe it’s part of Material Setup — what do you have “Rapid Z Gaps above material” set at? Clearance Z1 and Plunge Z2 — default should be 0.2"


Looks like Z1 = 1" and Z2 = .2" ?

1 Like

Yes, that would be correct.

1 Like

Well it was the Z height as stated above many times. I never realized it because I never use stock bigger than .75 so it never mattered. Thanks for the help…


With my S3 and VCarve I use the MM gcode processor… The inch option didn’t work.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.