Homing error after running fine for days (Solved)

I have been cutting parts with my XXL for several days with good results. This morning I loaded a job and when CM started to home the machine it crashed hard into the top of Z and gave me the homing error.
I have done the following:

  • Manually checked that all homing switch could move in and out with my finger. So no obstructions
  • Opened the controller case (ver 2.4e) to find the red and green light blinking. I searched but could find no documentation on these lights, if someone can point me to that I would appreciate it.
  • Hit the white reset button on the controller board
  • Shut ever thing down and tried again. same issue
  • running CM ver. 4.0. 414 grbl 1.1f

Is there a way to test the z limit switch. If I hold the button in should a light come on or something happen that I can see in code somehow.?

Stuck until I can get this resolved

If you have a multimeter you can set it for continuity and put the leads on each of the switch wires (remove the connector from the control board first). If it beeps, it is working.

Thanks, I should have done that already, I just checked and the switch is GOOD. Hmmmm???

More Data for those reading this. With the cover off the controller if I manually hit any of the limit switches a blue light lights up on te controller board. I take it that this indicates the switch is sending a signal and the board is receiving it.
Still have the red and green flashing lights.

The red and green flashing lights indicate USB communication.

Please check that the machine can mechanically close the switches before reaching the limit of travel — if you have difficulties with this, loosen the hardware in question, pull it into a better alignment, then tighten. If that doesn’t work, you may need square up your machine.

https://wiki.shapeoko.com/index.php/Calibration_and_Squaring_the_Machine#Squaring_the_Machine

OK , I found the solution. This morning I saw a photo of a Shapeoko that had the Dewalt router mounted higher in the mounting ring, thus giving it more clearance. Me being such a clever chap decided to do the same. However I did not take into account the Sucket dust collector bracket that prevented the z axis from going home by hitting the router at the new height.

Well I learned a lot and yes I found the section that says when the red and green lights are blinking you are communicating with the PC.

Thanks for those that helped. I hope this post saves someone else some Issues down the line.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.