Homing issues on XL using carbide

Shapeoko XL has been working great. Then out of the blue today it starts it’s homing process by moving up and down then just coming straight forward and jamming against the front of the machine. I’ve tried uninstalling/reinstalling the carbide software. I’ve tried sending it is correct file data and even tried I believe it was /$25=1 in the mdi (or whatever it is). But nothing seems to be working.

Any help would be great as we have orders that need cut soon!

It’s theoretically possible for Grbl settings to be corrupt, so re-sending them is good thing to do to eliminate that possibility: https://docs.carbide3d.com/support/carbideupdater/#carbide-motion-v4

If the direction of movement changes, this is probably caused by a wiring fault — check that, if it’s not that, it’s probably a failure of the stepper driver…

Let us know at support@carbide3d.com and we’ll do our best to help sort this out.

I was wondering if it might be switch related, but I couldn’t replicate the issue with any creative limit switch fiddling I could come up with. I can easily replicate a similar-looking issue by twiddling the direction bits in $3 (Step port invert, mask) and $23 (Homing dir invert, mask), but I don’t imagine you’ve altered those recently. I don’t imagine you’ve swapped cables around on the two Y steppers, as that’ll invert Y as well.

Is your $3 set to 6 (invert Y and Z) and your $23 set to 0 (all homing switches on the positive end) when you go to settings and open the log, then send $$ in the MDI?

Okay, I was too busy playing with limit switches to finish this before Will, but I’ll post it anyway. :wink:


I honestly gave up for the night. Will check tomorrow for sure. Got a little too frustrated after 14 hours at my regular job haha. Thank you both for you’re help!

So tried to correct the corrupt file. And it actually allowed the machine to work and home itself back to normal. Was able to use my quick points just great and set to 0 so I could get it to cut.

I tried cutting out just a simple like 2x2 letter O and got about 3/4 the way around and just stopped itself. No progress after that. Now back to homing it self up on the Z then back about an inch or 2 then it stops.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.