Homing on the xxl Shapeoko

(Bob zambron) #1

Okay I have completed the assembly of my xxl schapeoko and am now at the homing section. My question I have carbide motion 4 which homing is activated by default. So prior to running homing I’m guessing I should have my machine connected to my computer and the machine turned on. Would that be correct?

0 Likes

(Nathaniel Klumb) #2

Okay, let’s see, basically…

  • Turn the machine on.
  • Open Carbide Motion. It will say “Not Connected”.
  • Click the button to connect.
  • (If you have not yet sent the configuration data to let the controller know what machine it’s running, go to the Settings page and do that so the controller knows which Shapeoko it is.)
  • With the machine now connected, click Jog to go to the “Jog / Position” screen.
  • Since you have not yet homed, it will show a message asking you to initialize. Click to continue.
  • The machine will home, and the Jog / Position screen will be ready.

(Other than only needing to send the configuration during initial setup, this is basically what you do whenever you walk up to the machine to start things up.)

2 Likes

(William Adams) #3

Correct.

You’ll still want to send the machine configuration though:

0 Likes

(Bob zambron) #4

Why would I need to run the update. My software downloaded is v4

0 Likes

(William Adams) #5

You need to configure the software for which machine model you have as noted at the link.

0 Likes

(Nathaniel Klumb) #6

You don’t need to run any update. The linked web page includes the instructions for updating, and below that it includes dated instructions for sending the config data. The only part you really need to know is that sending the config data to tell the controller what machine it’s controlling, i.e. the step I included in parentheses above, is necessary when you set up the machine the first time (and also if you ever flash new firmware). Basically, after you connect but before you do anything else, you go to the Settings page, choose the right machine (Shapeoko XXL, in your case), and send the config data.

(Incidentally, the instructions on the linked page have not been updated in quite some time. They still reference “Toggle Shapeoko Homing”, which apparently was still a thing in the early Carbide Motion 4 build used for the writeup. That no longer exists as a button, as homing is mandatory in Carbide Motion 4.)

2 Likes

(Bob zambron) #7

Thank you for all the help. If I have not learned but one thing that is everyone on here are great and if you ask a question someone is going to answer it for it and it will not take long.

0 Likes

(David Jordan) #8

Question regarding the selecting the settings of the machines. each time i open carbide motion i have to select the machine i have then send data . do you have to do this every time you connect ?

0 Likes

(Bob zambron) #9

I think so it’s the same for me.

0 Likes

(Nathaniel Klumb) #10

When you send the config data, what you’re actually doing behind the curtain is setting a collection of GRBL parameters on the controller based on what you’ve selected in the drop-down. Those settings are stored in the controller itself, so once they’re set, they stick, even if you switch to a different program instead of Carbide Motion (or switch to a different computer). You only need to do this once when you’re setting up the machine and never again unless you install an update on the controller (or you want to get everything back to stock after playing with GRBL settings yourself).

As far as I can parse it, the drop-down box on the settings screen is just an example of poor UI design. Carbide Motion does not read the settings and figure out what machine they reflect, so it will always say “Shapeoko 3” regardless of configuration. It would be much less confusing if the drop-down was not hanging out there the whole time – it is only needed when you want to (re)send the stock config data, so a less confusing design could be to just have a button to send the config, with a prompt for machine type shown at that point.

1 Like

(William Adams) #11

That shouldn’t be necessary — as @ClayJar notes, on some (all?) systems it doesn’t read the machine information and adjust the drop down menu.

0 Likes