Homing problem (I think)

Ok, I hope this is not another false alarm.
I tried homing the machine per the instructions and it appeared to start with the X axis, but apparently failed. The head was all the way to the right and against the sensor (red light on) but tried to keep going. I had to hit stop. I checked the cabling and confirmed that the X axis cable was plugged into the correct connector on the controller. Then tried it again and got the same result. What should I check next?

ok what you can do is go to the Settings screen in Carbide Motion (connect to the machine, but do NOT initialize). In that screen there is a “GRBL Active Input pins” section, that will show you which input the controller gets. It should normally be blank – but when you put some metal (say a wrench) near a limit switch, the right letter should be shown there. This is the easiest way to check if all limit switch connectors are connected to the right pins… just do one at a time with the wrench and check if the right letter shows


Ok, Ive done this and found it blank and it indicated so. I put a metal wrench against the sensor and the red light lit and an X showed up under GRBL Active Input Pins. Removing the wrench set it to No Active Pins. Problem persists if I try again.

Please contact us at support@carbide3d.com

ah…by email, phone or what?

Please send an e-mail to support@carbide3d.com

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.