Homing problems CM 367

So I went to enable homing on my Shapeoko 3, following the instructions here:

Tried to home it, but the spindle hit the rails and I had to shut off the Shapeoko. Tried to jog it back, but CM wouldn’t let me. Uninstalled CM 367 and re-installed. Tells me the limit switch has been hit, gives me no options.
Realized the instructions I followed specified GRBL1 - evidently, l have GRBL .9 although my machine is only about a month old.
Many thanks for your help. I’m stuck - both literally and figuratively.

If it were me, I’d first verify all the homing switches were plugged into the right connectors on the board.
Then I’d upgrade my board to grbl 1.1 via the instructions here:

Read them all first, them go back and work through them. This process should get your grbl updated to 1.1 and your version of CM updated to 4.x. Once there in CM, do a “send config” to your machine from the dialog. This should set everything you need for your machine. Try homing after that.

1 Like

Thanks, Adam. I’ll try that.

A few notes:

  • you may have a bad homing switch — please check that they work by pressing them and verifying that a matching light lights up on the control board — also verify that mechanically the machine can reliably hit the switches before any other part
  • switches might be mixed up — please check that the right light lights up
  • the machine can’t know which switch it’s on when starting up against a switch, hence it going into alarm state. Power down and gently move all the parts a little bit towards the center of the table, then try again.

If the above check out you can forego re-flashing to Grbl 1.1 and upgrading to CM4 and stick w/ CM3 — your choice on this, but I think it might be easiest to get things going w/ the stock configuration


Thanks, Will. We’ve checked all the wiring, and everything seems to be correct. Homing switches are lighting up as they should, and I’ve tried manually repositioning, but CM is still doing the same thing. (I didn’t mention this before, but several of the buttons in CM have been appearing without text ever since we started using it, despite several attempts to uninstall and reinstall. I was hoping that somehow enabling homing would fix that, but that’s not the case.) So, I’ve gone back into Settings and set “Has Homing” to “false,” and set $22=0 in MDI. No homing, and text still missing from buttons, but at least we can use the machine again.

We have a new build, 368 which should sort out the blank buttons: http://carbide3d.com/downloads/

For homing, please review the setup at: http://docs.carbide3d.com/shapeoko-faq/shapeoko-enable-homing/ — if that doesn’t address things, either try CM4 as @Adam_Xett suggested, or contact support@carbide3d.com and we’ll have someone help you puzzle this out (if Skype or FaceTime is an option, let us know, along w/ contact times w/in California business hours which are convenient for you).

Thanks, Will. I tried to download 368 the other night, in the hopes that might fix it, and was getting a “not found” error. I’ve got it now, and will follow your suggestions.