Homing sequence problems

I finished my shapeoko built about a week ago, and the home switches and homing sequence worked like a charm.

3 days ago it suddenly stopped working.

  1. z-axis drives up, hits the switch, back off a bit, and creeps up on it. all good
  2. y-axis drives back, hits the end switch, and motor whines. y axis does NOT back up, and does not creep up on the y switch again
  3. x axis isn’t moving
  4. machine and software are stuck in the ‘wait for home complete’ and only way out is turn off the machine, and restart carbide motion
  5. same effect on mac and PC, latest carbide motion

trouble shooting done so far:

  1. log shows x, y and z switches working fine (PN:X Pn:Y and Pn:Z show when i press the switches
  2. GRBL 1.1 reinstalled, reflashed
  3. $22=1 set (again, to enable homing)
  4. tested with a 10mm gage block in front of the Y switch: gantry stops exactly 10mm shorter than without, but the motor whine continues, and the home sequence never finishes.

can somebody point me in the direction why i can’t home my machine anymore?

do you have mechanical switches or the contactless ones?

if you have the mechanical ones, best trouble shooting I’ve found is turn off the machine, and then by hand move the gantry to the point where it should make contact… usually I find something that blocks this. I’ve had my router cable block things, but also pieces of debris/wood that got in the way. And early on I had the thing that keeps the belts tightened block progress… but I fixed that by slightly turning that out of the way

1 Like

I have mechanical switches. while the machine is new and unused yet, i used the gage block method as a trouble shooting step. as I said, it stops 10mm shorter now (confirmed with dial indicator), but still doesn’t finish the homing sequence. there is no mechanical reason (without 10mm gage block), as there is another 4mm of travel until the gantry hits the hard stop.

so if you move it by hand with the machine off, you CAN get all the way to the back?
(that’s odd… almost always here and my own experience it is either a mechanical block so that the gantry just cannot get all the way to the switch OR the switch is misaligned and it misses its contact… your gage block should be big enough to rule out this second element)
also please check both X and Y… wondering if it’s your X that is missing not the Y

1 Like

when i start off the machine with Y switch closed (almost at the end), as well as the X switch closed (almost to the left), the homing cycle will pull off the Z and the Y, but will leave the X in place. it will then finish the z homing, i believe it just finished a y homing, and give me an error the x switch didn’t clear (because it didn’t move the x axis to clear it)

if i start the homing sequence with all homing switches clear of their end stops, it does exactly what was described in the first post.

the original homing sequence was z, y, x

is this a carbide motion (v513 and v514) bug? or GRBL bug? or user error?

In that case, what has most likely happened is the X-axis movement is failing, or the X-axis switch is stuck on.

Check the wiring, pulley set screws, belt tension, &c.

You can check the stepper driver by powering down, swapping the X and the Z connectors, powering up, going to the Settings pane, switching to belt drive, then initializing the machine — if the X-axis doesn’t move when connected to the Z-axis stepper driver then that has failed. Go back to Settings, change things back, power down, then swap the connectors back.

Let us know at support@carbide3d.com and we’ll do our best to work through this with you.

that was a good clue. the X axis was indeed “dead”. I unplugged the x stepper and ‘shortened’ one of the phases. this is an easy way to identify the phases of a stepper, but they all create no mechanical resistance, not like the other steppers. the other steppers have a nominal resistance of 2.1ohm, the x stepper has 1.9ohm on each phase. I think the x-axis stepper died without having done any work ever…

1 Like

so time to drop this into an email to support@carbide3d.com … they’re pretty darn good at getting replacements out

1 Like

Where did you disconnect?
Did you check any connections in the drag chain?

Problem solved: grub screws on the x stepper motor axis were loose

I took out the x stepper motor to see if i can see anything wrong with it, since I had never seen a stepper die on me in my life. sure, there is a first for anything, but highly unlikely. it was a bit embarrassing to see that it is (like so often) a user error where the grub screws either came loose or weren’t fastened by the user (me).

Thank to William to nudge me in the right direction.


In general if a machine won’t home it is often a mechanical issue. Sometimes the router cable is out of place and can keep from homing.

Great you got it fixed. This good practice for the future. Always go step by step. Some people replace the stepper motor grub screws with cap screws. The bigger head are easier to tighten. Also use a marker and put a witness mark across the stepper motor shaft for a quick visual check.


The first few months of ownership it’s really worth carrying out the maintenance checks from the e-book regularly. Each time I found something that had come loose it got a drop of Loctite 242 on it.


Part of me had hoped that 9 years of messing around with 3D printers (Ultimaker) as well working with my granite 1324 had given me some headstart for problems like this. But the reality of 6+ months of brainfog from f’ing long covid seems to have cost me quite some IQ points. I miss them, hopefully they come back next year.

Anyway, thx for the help and ideas, much appreciated. probably wasn’t the last time i am going to ask questions.

but it is interesting to basically see parts sold in 2015, and how much has changed in the design of the shapeoko since then. taking it apart and putting i together, has me already convinced that i need to machine a couple new parts for the shapeoko to make small details better for me. and once this machine is running, it will probably make parts to improve itself as well :slight_smile:

1 Like

Arjan, in the last 15 years of me being involved in various products with a public forum attached, posting a problem, and getting a solution, or working out a solve with the community as well as knowledgeable members of that company has always been more successful than reaching out to support. it has two benefits: it is documented, and others may hopefully be able to learn from it as well. neither happens when you contact support directly.


I think that was the best option (contacting support) when you were sure it was a bad motor. I completely agree with your statement. I never like when I see a forum topic end with “I sent the files to support” or something similar.

1 Like

To replace the motor with a new one… support it is,
For all other things… we’re all here together


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.