Homing (wiring) seems backwards

I just installed a replacement grbl board tonight and when homing the Z axis moves first and wants to go throught the wasteboard. I double checked and am certain I hooked up the steppers to the correct ports. My board is upside down, another words power and usb port on right side when facing the board from the back of the machine.

I wonder if the prior Carbide Motion software is not compatable with the new board. Maybe ai need to reinstall the newer version?

Or is it I simply have to swap the x and z plugs since my board reads upside down?


There are a couple of things which control direction of travel:

  • software settings — make sure you have the correct defaults loaded
  • mechanical arrangements — the Z-axis spindle carriage plate being upside down will make it run backwards
  • wiring — the Y-axis can be reversed by swapping the two Y-axis connectors

Please see: https://www.shapeoko.com/wiki/index.php/SO3_Function_Test

Got it working finally. Had to set the value $3=0 to get the proper settings. It was initially set to $3=6 so everything was inverted.

Darned “CNC Math”, always gets me when I’m not looking. Way back when I was a kid in school, 3=3 and 0=0, and we walked to school, barefoot, in the snow BOTH WAYS, but some dumb clod and these new fangled tools had to re-invent math…kids these days, meh!

Joking, glad you got it working!


Please note that per http://docs.carbide3d.com/software-faq/shapeoko-3-default-grbl-settings/


is the correct default. Remember that when updating. I would suggest resetting the machine mechanically / electronically to allow the correct directional movement when set to the default.

When I set the proper default $3=6 all the axis move in reverse. I can understand if it did it that way from the start, but it worked fine with the older board. I didnt change any wiring. Ill see what we can do when we hook up the new control box. Right now I only replaced the grbl board on the x railing as it was originally designed.

I’ve found my machine sometimes loses it’s mind and inverts or confuses all the axis’ movement. Seems to happen have long job maneuvers… but I’ve had it just power-on confused too. Only solution I’ve found has been to dump my settings via serial ($$), connect with carbide motion, do a “send config”, the push all my dumped settings back in. Been a while since that’s been needed though…

Is there a GRBL setting that dictates probing direction of an axis?

Per http://docs.carbide3d.com/software-faq/shapeoko-3-default-grbl-settings/ there is:

$6=0 (probe pin invert, bool)

which per Grbl v1.1 Configuration · gnea/grbl Wiki · GitHub controls:

By default, the probe pin is held normally-high with the Arduino’s internal pull-up resistor. When the probe pin is low, Grbl interprets this as triggered. For the opposite behavior, just invert the probe pin by typing $6=1. Disable with $6=0. You may need a power cycle to load the change.

So, not easily accessible. If memory serves, it’s a compile time option.

so $6 should invert the direction of probing? Any idea if that also inverts X/Y probe direction?

I would just try it, but my workshop/garage is currently 0 degrees and I’ve had to move/unplug the Shapeoko to the floor so I could turn off the water supply which has currently frozen and ruptured :frowning:

No, $6 inverts the electronic high/low connected/not connected.

To control direction of probing you need to edit the Grbl Configuration source files and re-compile a Grbl with the changed direction settings.


That makes allot more sense :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.