How do i get a smooth result in the roughing cycle?


I use Meshcam 6 for the MAC to generate my files. When i run a roughing cycle, the Nomad leaves ‘walls’ standing (see bottom left corner of attached image for example). How can i fix that so i get a smooth result?


Oliver, try reducing the roughing stepover slightly. The wood is maybe flexible enough that the bit is pushing it aside as it cuts.


Thanks Randy, I will try reducing the stepover for the roughing from 0.1125 in to 0.1 or 0.09 to see if that makes a difference. I am not sure though if it happens due to the wood because it also shows the ridges in the simulator OpenSCAM as well.

That didnt work either, i reduced the stepover for roughing from 0.1125 to 0.10 but it is still not removing all material… Maybe i need to reduce it even more? Does anybody else have that issue using the standard nomad settings?

And ridges remain even after 0.9 inches…

OK, maybe it is something else. I always make my roughing stepover 50% of the cutter size and never have problems in cleaning. (I don’t have a Nomad but have been using MeshCAM since 2004). Maybe the cutter is smaller than it is defined in MeshCAM? I have read here of occasional mis-labeled cutters. But I have always found MeshCAM to be very reliable in its toolpath generation.


I will measure the cutter once the current job is done to make sure its the correct width, thats a good idea.
Here is another picture of the ridges.

Oh sorry, Oliver. I overlooked that you said the ridges show up in the simulation. I was thinking .125 cutter and .1125 stepover would be touchy, but you are using .250" cutter. (We’re having a parallel conversation over at the MeshCAM forum but I’m repeating here because not everyone might be monitoring over there also…)

You should definitely have enough overlap at 50% of the cutter size. What tolerance are you using in the toolpath calcualtion? Screenshot of your Toolpath Parameters screen is something I usually request over at the MC forum to help troubleshooting.



sorry yeah the cutter is a .125 and not a .250 cutter. I attached the settings in a screenshot of the item i am carving at the moment (same one the photo above is of).

Thanks again for the support!

You’re welcome, Oliver. I would try a .065" or .07" stepover and see if that helps. But it does bother me that the ridges are showing up in your simulation. You are using a good small tolerance value so the toolpath calculations should be pretty accurate to your intentions. If you can attach your gcode either here or on the MeshCAM forum I’ll run it through CutViewer, and if you’re willing I’d like to take a shot at your STL also.


Hi Randy! I uploaded the fie to the Meshcam forum since i cannot upload zip files here it seems.

Oliver, thank you for the files. I couldn’t open the MCF for some reason, but I ran your gcode through CutViewer. This screenshot is near the end of the roughing of the outer shape:

The .09" roughing stepover is actually reasonable for a grainless material like plastic, and the screenshot shows the expected cusps between the passes, but I think in your case since you are using a ball-ended mill and roughing along the grain, the tip of the mill is acting as a wedge and pushing the wood fibers to the side at the top of the cut, producing the fins you see.

Even though I really like roughing with a ball-end mill in plastic and metal, especially when the geometry is curvy, in this case I’d recommend trying roughing with a square-ended bit and see if that helps.

I also think rotating the STL and rawstock so the grain was crosswise to the roughing cuts might help, even with the ball-end cutter, becuase then you’d be roughing against the grain. Unfortunately MeshCAM doesn’t have an option to pick the roughing direction with parallel roughing. I guess another option would be to un-check Use Parallel Path under the roughing, which would cause MeshCAM to use contour-offset roughing. But maybe if the wood is soft enough either of these two options might cause tearing of the grain. You’d just need to experiment some. Hopefully your wood is not too expensive. :slight_smile:


Hi Randy!

thanks again for checking into this!

Yeah i will
try next time to change it maybe to even smaller stepover. My goal is
to not have to do too much manual cleanup. And yeah the wood is very
very cheap, about 60 cents per foot so im not too worried about that,
its mainly the wasted time
I am still learning the wood carving and the machine, and i still don’t
fully trust the machine since i had some bad experiences where the stock
came loose since the Nomad doesn’t have a vice and just uses double
sided tape to hold the stock down, which i believe is a big issue since
multiple times the wood has come loose even though it was super tightly
glued on at the beginning. The wood seems to bend sometimes towards the
end of the cutting job which causes issues like that.

I will try to run another job later using the even smaller stepover of 0.5 and
cutting against the grain to see how that works. I am not sure if the
Nomad will notify me when to change the bit (and recalibrating for the
changed drill-bit is probably a different issue too) so I will stick to
one bit for now.

Thanks again for the great help on this Randy!


It could be a poor fit between the y axis cable and the platform. I had this problem. For an example image and solution see the thread on y axis backlash where this was discussed about 2 weeks ago. Try this: with the motors on, can you move the platform with light pressure? if so, that is the issue, that movement is reflected in every other pass when roughing in the x direction. That play allows the part to move into or away from the cutter enough to make the ridges. link here Backlash on y axis?


good idea but when the motors are running, i cannot move the platform at all, so I do not thing that issue is related unfortunately.

Also, the ridges show in the simulator already so I am wondering if its more a meshcam issue instead.


I actually just read your post again carefully and i will check later once i get home if there is a little play in the platform, so far i have only checked for if it moves but not if there is any little movements possible.

Ill check on that!


So i just tried it and it wiggles a bit, but barely any, like maybe 0.3mm (NOT inches, mm).
Is that amount of play ok?

.3 mm is enough to cause issues. easy fix, just flip machine on side, remove the 2 bolts holding the platform to the belt, ( some sort of metric Allen wrench), stuff something thin and stiff between belt and platform, re tighten bolts.

1 Like

Per the other thread on y-backlash, I was also having this issue, and resolved it by sticking a piece of plastic sheet-stock cut-to-width in, and then tightening the nuts down good and tight. Rob had mentioned there was a batch of belts that came through that they discovered (in part because of people like Mark and I reporting the issue) that were thinner than the other belts, so their standard clamp-bar arrangement has too deep a groove and allows play that it shouldn’t.


Jorge helped me to figure this out. The trick that finally did it was unchecking the angle limit checkbox in Meshcam.
Now they come out super smooth .

Thanks again Jorge!