How do i get a smooth result in the roughing cycle?


sorry yeah the cutter is a .125 and not a .250 cutter. I attached the settings in a screenshot of the item i am carving at the moment (same one the photo above is of).

Thanks again for the support!

You’re welcome, Oliver. I would try a .065" or .07" stepover and see if that helps. But it does bother me that the ridges are showing up in your simulation. You are using a good small tolerance value so the toolpath calculations should be pretty accurate to your intentions. If you can attach your gcode either here or on the MeshCAM forum I’ll run it through CutViewer, and if you’re willing I’d like to take a shot at your STL also.


Hi Randy! I uploaded the fie to the Meshcam forum since i cannot upload zip files here it seems.

Oliver, thank you for the files. I couldn’t open the MCF for some reason, but I ran your gcode through CutViewer. This screenshot is near the end of the roughing of the outer shape:

The .09" roughing stepover is actually reasonable for a grainless material like plastic, and the screenshot shows the expected cusps between the passes, but I think in your case since you are using a ball-ended mill and roughing along the grain, the tip of the mill is acting as a wedge and pushing the wood fibers to the side at the top of the cut, producing the fins you see.

Even though I really like roughing with a ball-end mill in plastic and metal, especially when the geometry is curvy, in this case I’d recommend trying roughing with a square-ended bit and see if that helps.

I also think rotating the STL and rawstock so the grain was crosswise to the roughing cuts might help, even with the ball-end cutter, becuase then you’d be roughing against the grain. Unfortunately MeshCAM doesn’t have an option to pick the roughing direction with parallel roughing. I guess another option would be to un-check Use Parallel Path under the roughing, which would cause MeshCAM to use contour-offset roughing. But maybe if the wood is soft enough either of these two options might cause tearing of the grain. You’d just need to experiment some. Hopefully your wood is not too expensive. :slight_smile:


Hi Randy!

thanks again for checking into this!

Yeah i will
try next time to change it maybe to even smaller stepover. My goal is
to not have to do too much manual cleanup. And yeah the wood is very
very cheap, about 60 cents per foot so im not too worried about that,
its mainly the wasted time
I am still learning the wood carving and the machine, and i still don’t
fully trust the machine since i had some bad experiences where the stock
came loose since the Nomad doesn’t have a vice and just uses double
sided tape to hold the stock down, which i believe is a big issue since
multiple times the wood has come loose even though it was super tightly
glued on at the beginning. The wood seems to bend sometimes towards the
end of the cutting job which causes issues like that.

I will try to run another job later using the even smaller stepover of 0.5 and
cutting against the grain to see how that works. I am not sure if the
Nomad will notify me when to change the bit (and recalibrating for the
changed drill-bit is probably a different issue too) so I will stick to
one bit for now.

Thanks again for the great help on this Randy!


It could be a poor fit between the y axis cable and the platform. I had this problem. For an example image and solution see the thread on y axis backlash where this was discussed about 2 weeks ago. Try this: with the motors on, can you move the platform with light pressure? if so, that is the issue, that movement is reflected in every other pass when roughing in the x direction. That play allows the part to move into or away from the cutter enough to make the ridges. link here Backlash on y axis?


good idea but when the motors are running, i cannot move the platform at all, so I do not thing that issue is related unfortunately.

Also, the ridges show in the simulator already so I am wondering if its more a meshcam issue instead.


I actually just read your post again carefully and i will check later once i get home if there is a little play in the platform, so far i have only checked for if it moves but not if there is any little movements possible.

Ill check on that!


So i just tried it and it wiggles a bit, but barely any, like maybe 0.3mm (NOT inches, mm).
Is that amount of play ok?

.3 mm is enough to cause issues. easy fix, just flip machine on side, remove the 2 bolts holding the platform to the belt, ( some sort of metric Allen wrench), stuff something thin and stiff between belt and platform, re tighten bolts.

1 Like

Per the other thread on y-backlash, I was also having this issue, and resolved it by sticking a piece of plastic sheet-stock cut-to-width in, and then tightening the nuts down good and tight. Rob had mentioned there was a batch of belts that came through that they discovered (in part because of people like Mark and I reporting the issue) that were thinner than the other belts, so their standard clamp-bar arrangement has too deep a groove and allows play that it shouldn’t.


Jorge helped me to figure this out. The trick that finally did it was unchecking the angle limit checkbox in Meshcam.
Now they come out super smooth .

Thanks again Jorge!



Great project.

What type of wood are you using, and how did you determine the federate and plunge rate settings for that wood?

Very nice result, Oliver!

But I don’t understand why unchecking the angle limit would make the change. With a 50 degree limit on the parallel finishing and 40 degree limit on waterline, there is a 10 degree overlap between the two regions. For years on 3D parts I have regularly used 47 and 43 degrees as the limits, and that is still enough overlap while using each finishing technique where it is most efficient (parallel on flatter areas and waterline on steeper areas). There is no angle limit on the roughing–it always roughs the same. Unless there is something different about the “Carbide/Nomad” version of MeshCAM than the “free range” version…


Thanks! Yeah I am not sure why it works exactly, but im very happy THAT it works now :smile: Maybe Jorge or Robert can explain more details on this.
@3dsteve: Thanks, I used a Jatoba wood, but i actually like the (local) redwood burl that i used before better in some ways :slight_smile: If you meant me anyways and not Mark.


Did you start with an STL of the car, or get a DXF and have meshcam ‘extrude’ it into 2.5D?

I am trying to decide if I am better off to design something in one of my CAD packages and export an STL that contains all the depth info, or just use a DXF for the shape and then use Meshcam functionality to get the depth info.

What feed rate did you use on the wood?

Once again, what a great looking project!


I used a STL of the car, which i think is the preferred way. Using a bitmap works too but i think using a STL gives you more control over the output.

I used all the default settings of the Carbide auto path. Took a few hours to carve this.

Thanks again :slight_smile:

what exactly IS surface angle?

A good question, dr_g. Surface angle is the local slope of the geometry relative to horizontal. A horizontal surface has an angle of 0, and a vertical surface has an angle of 90. As I said above, parallel finishing is more efficient on surfaces between 0 and 45 degrees, and waterline finishing is more efficient on surfaces between 45 and 90 degrees, for a given stepover/stepdown.

I allow a few degrees of overlap between the two regions just to make sure everything gets machined.

And for ultimate surface finish if time is no issue, use X+Y parallel and waterline with no angle restrictions over the whole workpiece, as I think Oliver did above.




thats correct, i used X+Y parallel and waterline with no angle restrictions. The X+Y Takes a lot of time and i wonder if just X or Y would be sufficient too.

Good explanation Randy!