How do I get motion to see my FreeCad files

Hello everyone, I’m new to this site. I’m running a shapeoko 3XXL and I can’t seem to get motion to see the nc file that freecad creates for my 3D drawing, no matter how I export the file. Has anyone run into this issue and know what I might need to do to correct the problem? I’m using freecad because create can’t draw a 3D object like the one I’m making. The drawing is not complicated it’s a plate (.75" x 20" x 24") that has a radius (concave) pocket in the middle (.25" deep) with a very large radius (30ft) which creates a shallow dish pocket in the part.

Can you share the exported gcode here?

This is a copy of the first page, there are 45 pages total (in word doc format)

;Exported by FreeCAD
;Post Processor: centroid_post
;CAM file: VCwoodworks pics/60 Foot Plate 01.FCStd
;Output Time: 2018-12-19 12:02:20.246000
G90 G80 G40 G49
;begin preamble
G53 G00 G17
;begin operation
;Default Tool
M6 T1
M3 S0
;end operation: Default Tool
;begin operation
G0 Z29.0500
G0 X22.6859 Y551.5411
G0 Z27.0500
G1 X22.6859 Y551.5411 Z19.0500 F12.7
G3 X7.3449 Y536.2001 Z19.0500 I221.7246 J-237.0656 F12.7
G1 X22.6859 Y551.5411 Z19.0500 F12.7
G2 X37.7832 Y564.8706 Z19.0500 I221.2309 J-235.3562 F12.7
G1 X2.5000 Y529.5874 Z19.0500 F12.7

Should just be a matter of the extension, see

Thanks Will, changed the file extension to “.egc” and motion could see the file but it would not load it and gave an “invalid g-code” error as the reason? Maybe there is something in the beginning of the freecad file that motion doesn’t like/recognize? At least the controller is seeing the file now, so that’s a good thing. I’m wondering if I should try a small scale version of the project and see if it’s something in the beginning of the gcode or maybe it’s something deeper in the file? I’m familiar with gcode but only from an operator/machinist perspective not a programmer.

egc means encrypted g code. try just .nc

1 Like

Thanks Mike, Freecad allowed me to save it as a “.nc” file and motion didn’t even see it. Once I changed the the extension to “.egc” motion saw it but didn’t like it. So I guess that’s progress?

You can’t actually use egc unless it’s encrypted. Try .gc It should see .nc, that’s what I’ve used for quite some time.

1 Like

Any solutions to this problem? I tried to save the FreeCAD export to .gcode, but when trying to open it with Carbide Motion, it says “No File Loaded”. Attached is the file generated by (2.8 KB)

Have you tried loading the file in CAMotics to see if it loads?

Maybe you should post the .nc file here and I’m sure someone will look at it.

1 Like

With bCNC it works now. There was only one problem: FreeCAD exported the command G20, which means inches for all measures. But then it generated all coordinates in millimeters. After changing this to G21, it worked. I can do it now all in Linux, no need for Windows or proprietary closed-source programs like Carbide Motion anymore.