How hot does your shapeoko3 controller run?


Just wondering if someone actually measured how hot the stepper driver components on the controller board get during long/high-load runs. Even though the heatsinking from the underside of the board looks ok, I consider sticking an extra 8x8mm heatsink (originally intended for raspberry pi) on the TOP side of each of the four stepper drivers, to have (more) thermal margin. Overkill ?


1 Like

The extra heatsinks won’t hurt anything, but they likely won’t help much either.


I just finished running a series of 9x ~1-hour long jobs back-to-back yesterday, after 9x ~45 minute jobs on Monday (roughing and finishing passes) with additional shorter jobs cutting the fixturing and a few minor adjustments along the way, and the only issues I ran into were from things coming loose (because let’s face it, this thing is bolted together, and I didn’t want to loctite things in a way that would make it hard to service in the future) and from material getting caught under the v-wheels causing it to jam up & skip steps (cutting tooling board and don’t have an adequate dust-head completed yet).

So like Mike said, probably don’t need them, but they won’t hurt.

Allright, thanks for the reassuring feedback. I think I will check how hot they get on mine, out of curiosity, and then stop worrying about it.

In case anyone is interested, I will leave my results here:

  • idle temperature on stepper driver chips 10 min after power on: ~95°F (35°C)
  • after a 10min surfacing job, the X and Y chips were around ~105°F (40°C)
  • I then ran a 40min surfacing job (feedrate 63in/1600mm), the X and Y were at 115°F (46°C) at the end

So, definitely no need for extra heat sinks.


I connected a laser diode to my S3 XXL and used Lightburn to make some cutting. After around 3 hours the homing process started to fail, the Z axis did not stop with the switch. I moved to Carbide Motion and resent the config and the same happened. Before that, I didn’t use my S3 XXL for a month so I don’t know if the wiring of the laser or something happened to the board while idle. I disconnected everything following the recommendations on the forum and the next day it worked, but only for a while. I measured the temperature of the stepper drivers and when it was working the max mas 119F however when it failed I measured 132F.
I connect the Shapeoko to its own outlet on the wall. I swap the X and Z steeper cables, nothing changed.
I look for a new board but they are out of stock.

Hi Adelio,

If I understand correctly, the intermittent problem you have is with the homing, and specifically the Z axis not stopping ?
If so, there is no link with the X/Y/Z stepper motors, it would more likely be a problem with the Z axis limit switch.

With the machine powered up and connected in CM, if you go to the Settings menu, and bring a metal object near the front of the Z switch (assuming you have the proximity switch version, else just push the switch button if you have a mechanical switch). Do you see “Z” being displayed in the “GRBL Active inputs” section in CM ?

Right now, It worked well. It shows Z as Active inputs. The homing process worked as it did yesterday; however, the problem starts after using it for a couple of hours.

Ok, it may be an intermittent wiring issue somewhere in the cabling to the Z limit switch. Next time this happens, try and do the test I mentioned above: this should allow to confirm whether it’s a wiring quality issue. When you have the problem, if it goes away by just wiggling the wiring around, then this is an even better sign that this is related to a poor connector/wiring quality.
In any case, feel free to contact to let them know about this problem.