How To Fusion 360: Simple Wine Rack

I figured I’d post his here. Hopefully someone gets some benefit out of my video.


Thanks for posting this. Great job. It always makes me smile hearing the “ahhhh’s” when mistakes or things aren’t going the way you want. I do the same thing even when there is no audience haha.

Keep them coming!

Which post processor did you use? I have a very simple clamp model that I made in Fusion but I haven’t gotten Carbide Motion (3.57) to work with it yet. I’ve tried using the Carbide, GRBL, and Mach 3 post processors, with G28 turned off, radius turned off, etc. The .nc files load into Carbide Motion and when I click run, they ask me to put in the right tool, but then they immediately freeze once I click continue. I’m not sure what its getting hung up on, but I’m very eager to get this working. The .nc files all load fine in CAMotics and look right. I’ve even tried reducing the tool booth to the simplest 2D operation that would work fine from Carbide Create, I just need to figure out how to get it to work at all.


Interesting that the carbide post didn’t work. I’m guess an invalid command might be making into the gcode. Could you perhaps upload the gcode file and I’ll take a look?


In your fusion file try removing the beginning % and ending %. Also remove the T# M6 as well as the M9 commands and see of that sends.

Hmm. I started from scratch again, this time only using the Carbide post processor, and it worked perfectly! I tested it with a few 2D operations, then did a 3D contour, which my reason for wanting to move beyond Carbide Create.

Now I need to figure out why Fusion is scaling my SVG files and how to correct it. I had originally carved 4 hold-down clamps from the SVG on Inventables website (although I enlarged the slot and hole to accommodate 1/4-20 screws rather than M5 ones). The chamfered edge at the front I just created on a belt sander. I then broke one of my clamps and decided that making a new one would be a great opportunity to learn Fusion, and I should even be able to have it carve the chamfered front edge rather than doing just a straight 2.5D cut. As you can see in the picture, that all worked perfectly, except the new clamp is exactly 75% of the size!

This scaling happens right at the beginning when I import the SVG onto the Z plane, but bizarrely, I haven’t been able to correct it, even though there is a XY scale option when inserting an SVG! If I leave the scale at 1.00, the sketch comes out 75% of the size it should. If I set the scale to 1.333, the sketch comes out 33% bigger than it should! I’ve tried using 1.01, 0.99, 1.25, 100/72 (figuring it was a problem converting pixels to inches), but none of them behave the way I expect.

I’d greatly appreciate any help, and happy to upload my SVG or Fusion file, although this forum does’t seem to allow either format. Thanks!

1 Like

I’ve been having problems with things coming out scaled way up when imported into meshcam after coming out of fusion - there are times it won’t give me the choice between inches and mm…and I originally built it in mm, but it assumes inches for whatever reason. sometimes things are some different scale too than a mm/inches (25.4x) ratio. I have no idea what causes this. I’ve also had cases where it all comes out exactly fine. I don’t know what is causing this for me, but it’s pretty frustrating. It’s getting close to making me want to use fusion cam instead.

Hey Mike-
I’ve stayed in inches (I think) so haven’t even gotten to those problems yet. But I am having this 133% problem that @WillAdams wrote about on the Inventables forum a year and a half ago. My drawing is the right size in Graphic (iDraw), but the resulting sketch in Fusion is 75% of the correct size. Yet if I tell Fusion to scale it up by 133%, then it comes out 33% larger than it was in iDraw!?! In order to get it correct, I have to tell Fusion to scale it up by about 115.45%, which makes no sense to me.

When exporting from iDraw to SVG, it doesn’t matter what scale factor I tell it. I’ve tried 100%, 133%, 75%, etc, but Fusion imports those files all identically. (I’ve looked at the text of the resulting SVG files, which are always specified in pixels, I can see that the pixels have scaled appropriately as told by iDraw, but there must also be DPI info in there, since Fusion undoes it all.

I’m sure others have solved this and know more, so I’m hoping someone can help. (I’d use Inkscape, except I’m on a Mac and can’t stand running X11).

If you pull the svg directly into meshcam, what happens?

My MeshCam trial just expired unfortunately, but I’ve learned a bit more from making simple models and testing.

To simplify the test, I made a 2x2" canvas with just a 1" square at origin. That saves to an .SVG file that is 144x144 pixels with a box that is 72x72. If I import that into Fusion, I get a box that is .75"x.75". But if I tell Fusion to scale the XY plane by 1.33, I get a box that is 1.33" x 1.33".

OH! The problem is Fusion squares the area of the plane in both directions at once. So to get a box that is 1" x 1", I need to scale it by the square root of 1.333, which is ~1.1547, which is what I found empirically. Interesting!

This is the same whether I tell Graphic to scale the SVG file when it is exporting or not, Fusion sees it the same. Loading the file in Inkscape, I get different results. The non-scaled SVG file from Graphic loads as 0.809" (not sure where that comes from) and the scaled up version loads as 1.076" (close, but not that close).

In case this is helpful to others, I’ve uploaded the test files in this same thread on Inventables: