How to import Solidworks metric DXF into Carbide Create

(Leif Ilvedson) #1

I’m a newbie to Shapeoko…just got it set up and now diving into the software side of things.

I noticed when trying to import DXF’s from Solidworks (2013) into Carbide Create, there was a scaling issue when using metric. It seems Create has a simple mathematical error. With Create settings on metric, a 100mm circle will import in as 2540mm. This tells me that Carbide Create is thinking the DXF is coming in as inches and is converting it to metric (multiplying by 25.4mm per inch . . so in this example it thinks it’s importing a 100inch circle and converts it to metric).

The work around I’ve found for metric:
Before saving your DXF in Solidworks, go to your document settings (Tools–>Options–>Document Properties–>Units) and change your units to IPS. Then save as DXF. Set Carbide Create unit settings to metric. Now import your DXF (which is in inches) to Carbide Create and your 100mm circle will be 100mm, and positioned where you originally had it as well.

1 Like

(William Adams) #2

Haven’t the SolidWorks folks done an integrated CAM tool?

0 Likes

(Leif Ilvedson) #3

I was not aware of that. Thank you.

I’m just getting up and running with my Shapeoko 3. Until I see the need to move to Solidworks CAM, I’ll stick with the free Carbide Create and use the above mentioned work-around.

1 Like

(Stuart) #4

I personally don’t like the Solidworks Cam offering, I feel HSMWorks is far superior and much easier to use.

I have found similar issues with exporting solidworks DXF’s, and it can be fixed during export. There is an option in the export windows where you select Imperial or Metric. Even though my default units are metric, and my designs in metric, for some reason it will always default to export in Imperial.

I’m not on my PC, but will have a look when I get home.

Also maybe SW is exporting as Metric and even with CC set to metric it may be opening the DXF in imperial units? might be worth playing around with those options to work out where the issue lies

1 Like

(Brian Mears) #5

@stutaylo - I use SolidWorks & also don’t like their CAM. But this!:

HSMXpress for Solidworks is free and since made by Autodesk, feels and works a lot like Fusion. It’s only 2.5D, so depending on what you’re doing, maybe lacking a few features but I highly recommend trying it. Keep the SolidWorks familiarity, get (most of) the functionality of Fusion.

2 Likes

(Leif Ilvedson) #6

I’m using Solidworks 2013, which doesn’t have the export options you speak of. I’ve tried this in AutoCad 2015 as well with the same results and the same work around.

1 Like

(Stuart) #7

@brrian I did see that, awesome that they are offering it for free! It’s a shame they omitted adaptive toolpaths from the Free version of HSM, but for most jobs it’s got everything you need.

I like the Fusion360 CAM, which is nearly identical to the full version of HSMworks for SW, but I much prefer using SW for design and have access to the full HSMworks suite so use that and Vectric Aspire for most everything

@VikingVoyager I may have my wires crossed - on import of a DXF into SW you get the option to select metric or imperial. I’ll spend a bit of time tomorrow having a look as i have had the same issue but without looking at it in front of me it’s hard to remember what the fix was. If its no simpler than changing your units in SW as you have been doing, then maybe an email to Carbide support could get the option added to CC to import metric or imperial.

I use both SW 2016 and 2018

0 Likes