How to see grbl settings

How can I see the GRBL settings in carbide motion? I think I have the laser mode on but for the life of me I cannot find how to see the GRBL settings in carbide motion. Is there a good primer for this? I haven’t found one.

Go go Settings, click on the Log Windows button (lower left corner of the Settings page), this should pop up the Log window. Keep it open, now go to the MDI menu and send $$
The current GRBL param values should be displayed in the log

1 Like

That is exactly what I needed. How to I get it to change the current settings? I have tried typing $32=0 and /$32=0 and then $$ and the value is still $32=1.

This is so not intuitive. Are there any places where this is written on how to change these setting? I am going crazy searching and searching on how to do this type of thing and can’t find anything. There is a steep leaning curve to all of this (or at least for me…).

That should work, but we don’t support lasers, so maybe it’s disabled.

Please check w/ the folks who made your laser add-on and at their suggestion try this w/ a 3rd party tool suited to lasers.

Like Will said sending $32=0 should work. If you use some other software for the laser work maybe use that to revert $32? I have macros setup in Lightburn to toggle between laser mode and CNC mode (which includes toggling $32)

Thanks for chiming in guys. Do I simply have to enter “$32=0” and press send? I wonder why this does not work?

When this command gets sent, is it then a default? Is there a save command that also needs to be sent?

As a different follow-up, is there a way to make the Jog " fast setting" go a certain speed? it is slower than the rapid position speed and I would like to adjust it to a faster speed if possible.

Is there a way to a custom homing position instead of just the rapid position settings? Do I need to use a different program for that type of customization?

Without the quotes, but yes.

The new value should stick immediately, this is how GRBL works. No separate command to save.
After you modify the value, did you send $$ again to dump the GRBL values again?

Not that I know. It’s hardcoded in CM.

Not directly, but you can create a “Quick Action” with the line of gcode that does this. There are a few examples out there in the forum.

1 Like

thanks again for the help guys. It does not change when I enter the command in CM however it does in Lighburn. I will do it that way. I really appreciate the insight!

Mmmh. It’s weird that you cannot change it with CM. Just tested it with CM 548 and it worked fine.
It’s necessary to send $$ afterwards to see the updated value though. The log window is a bit confusing to my liking (with most recent traces showed on top, not at the bottom) and it’s easy to check the wrong trace, when in doubt I use the “Clear” button before sending the command.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.