Initializing w/ build 566

I have a fresh/first install of Motion and when I go to initialize, the router just traveled to the back/right corner and will only move about 20mm on any axis. Shapeoko 4

You must (re)select machine type in Setting such that “Travel Dimensions” are correct.

1 Like

I set it to shapeoko4 xl and default dimensions. I initialized again and the the router moved to the frot left corner and now makes a gawd-awful racket.

And what are the correct travel dimensions supposed to be.

I bought the machine used with no manual and I’m kinda feeling my way here

Documentation is on-line at:

You will need to disable the BitSetter in order to initialize the machine — once it is successfully initialized you can configure the BitSetter position and enable it per:

Bitsetter is disabled.

Bitzero = none.

No joy. The spindle goes up on ter z-axis, then bad noises.

To confirm: no homing switches are stuck on

Under Settings there is nothing active under Active Inputs in Carbide Motion when connected to the machine.

If you test the Z-axis homing switch does it register as the Z-axis under Active Inputs?

Please write in to

I don’t know. Wouldn’t even know what to do.

Don’t know, but I’ll check.

Geez. I dunno again.

I’m pretty sure that’s what I’ll do.

Do they have someone who can deal with a total know-nothing noob?

@WillAdams gave you link to setup of config.

If you connect to machine do not initialize. Go to settings in CM and in first tab select machine and Z. In second tab uncheck BitSetter, you can set up later, and also disable automatic spindle control, you can set that after initialization. Be sure to send config in first tab. The config is not really setting up the Shapeoko as much as it is configuring CM. As Will suggested in settings check that no active inputs are active, like a stuck homing switch.

1 Like

I’m sure this is all very good advice, but the truth is I haven’t got a clue what you’re talking about. More info would be helpful.

It would be helpful to know why the machine is behaving the way it is.

There are xyz setting that have values - what should those be?

You need to get the machine to initialize first. When the machine initializes the machine has two sets of coordinates. The first set is when the machine initializes it sets the X Y and Z references for the Shapeoko. Those are not used by you but by the machine. After you get initialized then you set up for a project by setting X Y and Z zeros according to what you set up in Carbide Create. The second set of coordinates you set up are referenced by the homing sequence which is called initialization.

So get your machine configured and initialized as a precursor to doing anything else. The initialization is fundamental to everything else. After you get initialized then come back if you have more questions.

To check for Active Inputs connect to your machine with Carbide Motion, do not initialize, go straight to Settings then click on Machine on the top.

Dude, that’s kinda what I’m trying to do.


I’ve tried to doeverything suggested, but the cutter is still sutck in the fron/left corner and makes a huge bad noise.

Is there a way to reset everything to it’s base/default setting so we could start from scratch?

Do you have the BitSetter enabled?

If so, disable it.

If you have difficulties w/ this, write in to

OK - the problem is solved. I managed to get the right machine, Shapeoko 3xl, plugged into Motion and this helped a lot. I played with the bitsetter, arranged for a support call and went to bed.

Right after lunch I got my support call. A guy named Eugene walked through getting my initialization and bitsetter correct and ready to rock. Took 30-45 minutes. Extremely helpful, knowledgeable and patient. The Carbide 3D support team deserves the reputation they have.

Many thanks to Eugene, and the folks here.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.