Inkscape and halftone help

Anyone explain how this halftone is done in inkscape? I’m a complete newbie to inkscape.

I’ve tried some of the other ways of halftoning and am not happy with the results. This looks like it might be what I’m looking for. Any help would be appreciated. Ray

Perfect example of why I mislike videos for didactic purposes (or anything other than entertainment).

Hopefully the person who made it will answer the query on what is happening and how others can do it.

If you’d enumerate the other things you’ve tried and what tools you have access to, and what the failings of the things which you’ve tried maybe we could puzzle out some other option.

@fiero1 I haven’t tried actually cutting anything with my $1,600 doorstop…but, this program seems easy and straightforward. It allows for dots, lines or squares with many creative options available. Simple to use and FREE.

1 Like

If you have some difficulty with the functionality of your machine, please contact and we’ll do our best to get the machine working to your satisfaction and its specifications.

That program and a number of others are listed at:

There are some filters for Adobe Illustrator which will instantiate various sorts of half-toning and line screens as vectors applied to greyscale and colour art — there doesn’t seem to be one for Inkscape (not listed at: ) — I suspect the technique used in the video you cite is to use a GIMP plug-in and create it as a pixel image — at that point, you might as well do the whole thing in a raster editor.

I highly recommend the program by jason Dorie listed above. Very easy to use.


One tip is to make sure your wasteboard is completely level and square to the router. Any deviation will change the size of the whole and distorted the image

1 Like

Very nice work. My biggest problem with Dorie’s software is it always wants to generate a background even when I clip the picture before loading. Now in fairness I have not cut anything through his program, I have only exported as a DXF and brought it into Vcarve pro. Every time there are vectors in the back ground area.

I use photoshop to remove the background and it’s no problem

so any background you remove in PS does not get cut when you run the gcode? Thank you Ray

@Murdocjx How are you getting the text file from Jason Dorie’s program into Carbide Motion? I’ve tried a bunch of things including changing the extension but am not having any luck. Any help would be greatly appreciated.


List of supported extensions for Carbide Motion:

  • .nc
  • .egc (for Carbide Motion)
  • .gc ?
  • .gcode ?
  • .tap (per Hello World file)

Thanks @WillAdams. The only outputs I could find in the haltoner program are .txt and .dxf. The .txt file appears to contain gcode. I have tried to change the .txt extension to all of the supported extensions with no luck when attempting to load into carbide motion.
I see that it can be done by the posts above.


I changed it to .tap

1 Like

If you click on the [Toolpath] tab, you can export G-code.

1 Like

Thanks @Murdocjx. I think I tried .tap but I’ll generate new code and try again. I REALLY am looking forward to making this work!

@BoscoBob I did write the Gcode using that button button the only save option is a .txt file. Thanks for your help though.

If I remember right you might have to delete the first line of code in the file after you change it to .tap. It’s been a while since I’ve used it though

I get everything loaded through and converted from .txt to .tap. I then load it in to carbide motion after removing the first line in the text file. It runs but it just sits there and vibrates in a very small area. Any one have these issues? I am assuming it has something to do with the code lines? What have other people done to get this to work?

If you wrote the code in inches try to rewrite in mm.I was having that problem in a diffrent program when running .tap files,worth a shot.

1 Like

Very, very, tiny movements are typically caused by a file being generated in Imperial, but the system assuming that it is in metric, so it comes out as 1/25.4th the actual size.

Opening the file in a text editor and adding the appropriate unit indicator (G20?) as the first line usually fixes it.

I would suggest always using a previewer when possible. The community has a list of them at:

1 Like

Yeah what mark said. Yo cut the gcode in inches and CM trades MM. Size everything up in the program the way you want it in inches then before you write the gcode just click mm. It does the conversion for you.

Also what bit are you using. I noticed in your screen shot that you had a 90 degree bit. If that’s true I recommend a 60 degree v bit instead.