Inkscape to CC Scaling down

I’m reading that this is a big issue that’s been covered a lot in the past and it’s odd to me that there doesn’t seem to be a fix or a simple way to explain it. I’ve read so many threads with different explanations and still cannot come up with a fix. The most common reply is to draw a rectangle for scale. I’ve drawn a rectangle box around the drawing for scale and the rectangle box comes through at full size which adds to the mystery but the geometry inside the box, the stuff that matters is always scaled down. Is there any known vector drawing programs that scale correctly when opening in CC? This seems to be a more recent issue as I’ve been using Inkscape and CC for a year or so now without this issue until just recently. Cheers, Seth

Inkscape’s de facto 96 dpi scaling factor has been explicitly supported by Carbide Create for a while now.

If things are the wrong size it’s usually caused by importing a PDF into Inkscape, then re-saving as an SVG — in that case, select everything after opening the PDF, copy it, create a new document paste things into that, then save as an SVG.

If you can document step-by-step how a file is made which comes in at the wrong size using a current version of Carbide Create we’ll do our best to look into it.


I’m doing my Inkscape drawings from scratch in Inkscape, saving as an SVG and then opening in CC. I’ve also tried saving as a DXF in inches and opening in CC and it scales down exactly at the same numbers as the SVG file.

@Seth Are you using the latest version of CC? It was resolved last year…I was one of the ones trying to drive the change and Carbide did respond well…Here’s what I do:

In Inkscape, I created a 4x8" Rectangle:

Then saved it as an SVG:

Loaded it into Carbide Create (v5.14) using the import icon:

Which loaded it.

Then clicking on the resize tool, I can see the object’s size and it’s 4x8"… scaled correctly:


It says I’m using CC version 431, Built on 2019-08-16

I’ll see if there is a more current one I can upgrade to.

Cheers Seth

Nomad 883 #1308

514 is the most recent on both mac and windows.

I’ve upgraded to 514 and the issue hasn’t changed. My file has simple 2D rectangles that are cut to accept accordion reeds. For example one is .575” wide and 1.300” long. When it’s opened in CC , now version 514, it’s becomes .545 wide and 1.270” long.

Cheers, Seth

Nomad 883

I did the 4x8” test as you posted above and using the import button in CC I get 3.99 x 7.99

My previously drawn files are still showing .545” where the drawing says .575” so no change there. Seems it’s closer to accurate the larger the drawing dimensions although you got exactly 4” x 8” on yours so I’m at a loss why mine is slightly off.

I’m now using CC 514 and Inkscape 1.0.2 both the most current. I must have some tiny scale factor somewhere that’s off. I’m not sure where to go next.

Do you have Inkscape set to include stroke width when measuring?

Turn that off.

1 Like

What @WillAdams said above.


I’ll check and see… it’s set on Visual bounding box?

I just did the test on my sons computer and emailed it to myself and it opened perfectly in CC so the issue lies on my computer in Inkscape. He is using 0.92 Inkscape, and I have even using 0.92.3 and 1.0.2 as well.


It seems that’s what the issue was. I don’t know how I ended up on that setting or how long it’s been that way but I’m going to have to redo many drawings it seems. As soon as I changed the setting on my most recent drawings it reduced the size in Inkscape to exactly what CC had been showing.

This is why I bought my machines from Carbide 3D, the community and service is amazing. Thanks for hanging in with me on this.

Lastly, is there a way to not have to redraw all drawings done in the last couple months, seems this happened when I updated to the last version of Inkscape and I’ve been drawing at least 100 hours or so of very intricate parts . Hopefully I can figure out how to save the files with the correct dimensions away from the ones done in Visual Bounding and save them to Geometric bounding without the dimension change?

Anyways, super impressed with you guys help.


Hamon Bagpipe Co.

You could do Path | Object to Path which should instantiate the outlines.

Oh wow, I never knew about this. Although I always turn my object to path like @WillAdams suggested and it eliminates the need for that.

1 Like

Ok, I manage to save my work from the past month. There may be a better way but I ungroup and copy in 0.93.3 , then paste in the newer Inkscape 1.0.2 downloaded today and saved on the Geometric Bounding setting and it somehow worked. Guess I’m all set and can get back to work tomorrow although I do want to mess around with the Object to Path thing you mentioned. Software can be crazy. Ok, no more updates, let’s keep everything the same, Lol…

Just glad it’s resolved and didn’t “re-rear” its ugly head!

By default, Inkscape uses the visual bounding box. It doesn’t affect anything dimensionally when you don’t have a stroke. The stroke follows the path. A thicker stroke will make an object larger than a thinner one, just like if you traced a line with wide highlighter vs a well sharpened pencil.
I typically try to keep the stroke as thin as any tolerances and then you don’t have to worry about it much.

This has been working well for the last 2 weeks but I’ve a design that I have spent most of the day on that is just not cooperating.

I have a file that comes up in CC just downsized like before. If I ungroup, copy, and group to path and pull it up in CC it shows up with a double poly line. The outside line is the correct size and the inside is the scaled down one. If I upload into CC without doing the Object to Path I get a single line as I expect but it’s the downsized size, same size as the inside line of the double line. I could delete each inside line manually which would take forever and may do that for now until I figure out why it’s creating this double line.

The Fill is off, no fill, and the stroke is on .010”

It’s pretty much the same as the sizing issue I had previously which was fixed by switching to Geographic Bounding or by Selecting Object to Path while in Visual Bounding.

I’ve tried every combination I can think of but I can’t get the double line to go away without ending up with the downsized drawing.

Change the objects from having a stroke to having no stroke and a fill.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.