Instructions for fitting a 2.2kw (or other power spindle) and VFD

I know! Right?
Yep, I forgot to mention the Z recalibration. Thanks for the reminder.

1 Like

There is one more thing I didn’t mention. I found a recipe that made the machine with the stock stepper work…

I was talking it over with my wife (who tolerates my interest in CNC with some grace). She said “have you tried swapping out the computer you are driving the machine with?”. Err, no… So I did. It worked! OMG something about my old laptop I guess? After kicking myself for not doing this earlier, I got to work on the routing job that had been on hold. I got my mouse from my old laptop and setup the new job on the new computer. Then, OMG it failed. Wait a minute, it worked reliably before (I did a 3d toolpath with loads of z-axis moves for about 45 mins.) The only thing that had changed was the new toolpath and the mouse… I unplugged my USB mouse and tried again. The job worked!!

I’d be interested to know if anyone else has had issues with other USB devices messing up their shapeoko? I’ve not read anything to that effect, but it’s pretty obscure. Probably I fell asleep before I read that thread! Also I never would have guessed a USB mouse might interfere.

I’ve not actually had a moment to try driving the shapeoko from the old laptop without the mouse. (and i’ve gone and messed up my control experiment by swapping the stepper in the meantime)

Ah well. Onwards!

So after some serious frustration and the Shapeoko stopping randomly mid job, Carbide support said I was getting electro-magnetic interference or a ground loop problem. After looking up what those meant, I got a multimeter out and discovered nothing is earthed on the shapeoko. The control board is supposed to be I believe, but I could not see it when I tested. Fortunately I had added a Z-probe, one side of which is grounded. So I ended up making a holder from aluminium hanging off a grounded copper water pipe near my shapeoko. Now that my touch plate is stored in a grounded state, (still attached to the ground pin on the touchplate connection on the board, the machine works perfectly even with the old mouse that gave me gyp earlier… So weird you have to discover and jump through these hoops to make the thing work…

2 Likes

I grounded everything together on a marine grade grounding bar. 120v, 240v, VFD, spindle, frame, and control board. Run spindle power through my drag chain without shielding. No issues, and don’t need a ground clip for my probe.

1 Like

Just installed the spindle and VFD and cannot get it to work.

If I go step by step using steveandrews settings the spindle starts up when I enter the value of 1 for PD001. I have to hit the stop button to make it stop and it never runs again. Ignores everything from the Shapeoke board and entering the value of 1 again does nothing.

Are there any updates on how to get this working? I am pretty sure I have it wired correctly since the same PWM signal starts my power supply relay just fine

Miglo mentioned needing a jumper J1 over V1. Could someone clarify this? Does he mean a jumper between them?

Thanks…

I think I found the jumper Miglo was speaking of. Changing its position did not help. Also, each time I power up the VFD the spindle starts and I hit the stop button to halt it. Pressing run or any series of M3 commands not the Spindle On button seems to start it again.

Setting the jumper on 1-2 keeps the spindle from starting on power up

Nevermind, I found Julien’s post which had different settings that now work for me.

1 Like

Which of Julien’s posts? I’m having the same problem you are, and want to make sure I’m referring to the correct one. Did using his settings resolve your problem? I’m about to give up on the whole thing and get a new machine that was purpose-built to use a spindle and computer speed control.

Very comprehensive discussion with the settings I used

[VFD Parameters (Huanyang model)](http://Juiliens post on VFD settings)

Dan, Thanks. That’s the thread I was thinking of. I’m still having the same problem you were having; as soon as the VFD boots up, the spindle starts running, and that is with the jumper in the correct (Pin 1-2) position and PD001/PD002 both set to 1. I hit STOP on the VDF, and the spindle never runs again. I’m seeing the correct voltage from the CM board, measured both at the board with the VFD disconnected, and at VI / ACM when connected. I tried a PD 013 reset and re-entered everything, but still no joy.

Can you double-check if you have PD011 set to 0 ?

I know you said you re-entered everything, it’s just a double check. Having PD011 set to something different from 0 would produce the same effect you are seeing. This is the “Frequency lower limit” parameter: the idea is that when you have an air-cooled spindle, it is important that the spindle never goes below a given minimal RPM, because then the fan would not produce enough airflow to cool the spindle when running. Since we are working with PD001/PD002 set to 1, this essentialy means that the “Run” button is ignored, and the spindle runs at whatever RPM is commanded by the VI signal from the Shapeoko. If PD011 was non-zero, when the Shapeoko sends 0V (as it does while idle), the VFD will spin the spindle at the frequency set in PD011, not 0 RPM.

This is assuming you are indeed using a water-cooled spindle. I’m sure people here who use air-cooled spindles could comment on how they setup their VFD parameters.

Sorry to hear you are still having issues. With the help of my wife I went through each and every one of the settings Julien posted, even the ones he didn’t change or highlight and made sure the jumper was correct and things started working.

Also, once you get past this, if you are using a sender other than CM be sure to go over all of your gcode parameters. If you don’t perform the step of homing followed by entering G28.1 in the console you will have issues as well.

Dan,
Thanks again. I’m going to re-run everything again today. Do you have a particular power-up sequence you use? I’m wondering if I should have CM up and connected to the Shapeoko BEFORE powering up the VFD at all?

Nope, no particular order. Hope you get it going, it was frustrating for a bit but once I got it figured out I am pretty happy.

@DanSexton did you see my post above about PD011? Just curious.

I will check mine but mine is working fine. I was trying to help Sea_Warrior with the problem I had before using your settings.

sorry, I mean to ask @Sea_Warrior and typed in the wrong name :slight_smile:

Julien,
Yes, thanks. I need to try seeing PD011 to 0 again and check that. I think I may not have had the other settings correct when I had it set to zero before. I’ve got an air-cooled spindle, but I don’t think setting PD011 to 0 is a problem. I understand that once spinning an air-cooled spindle needs higher RPMs to dissipate the heat than what a water-cooled spindle needs, but I can set my minimum RPM in Carbide Motion to ensure I keep the RPMs up any time the spindle is running.

On a side note, for you or Dan or anyone else who wants to comment: I’m not completely comfortable with the idea of shorting DCM to FOR directly. I feel like it would be safer to to put a toggle switch inline just to prevent any stray voltage on VI from spinning the shaft while I’m doing a endmill change. Thoughts?

Thanks, guys.
Troy

The problem is that adding a toggle switch on any of these signals will not necessarily bring additional safety, the likelihood of an internal failure is similar to the likelihood of something weird happening on VI signal. The only completely safe way is to remove power, i.e. turn off the VFD while changing tools…

1 Like

HI,
I’m following your steps and almost there…I hope :slight_smile:
You wrote “Change $30 to 24000 in the GBRL setting – this states that at maximum output of 5v on PWM will be 24000rpm – as default this would be 10,000 or 12000 rpm.”

My question is how to change $30? I am running Carbide Motion 513 running Carbide 3d 2.4d board.

1 Like