Is it Bitsetter, or is it me?

New here. S3 XXL with Carbide Motion build 521. I searched and found a possible answer. But the thread was closed, so I couldn’t seek clarification there.

I may have mis-categorized this, as I don’t know if it’s the Shapeoko, or Carbide Motion, or me. But I’m having issues with Bitsetter changing zero unexpectedly. I insert a new bit, set zero, and start a job. CM prompts me to insert the bit, which I’ve already done, and resume. Bitsetter does its thing. But then the Z axis buries the bit into the workpiece as if the zero is somewhere in the basement. I messed up a very complex and expensive piece of figured wood yesterday, and had to cover it with an inlay due to this very frustrating phenomenon.

I’m thinking maybe CM is changing zero wrongly, based on whatever bit I had installed for a prior job. However, setting the zero should have nullified that. So I’m not sure what’s going on. Can someone either give me a workaround if this is a bug, or give me an example workflow to correct my misunderstanding of how this is supposed to work? TIA.

There are a few questions to determine what may be happening.

  1. How are you setting the WCS or Zero in your cad software? Are you then zeroing the Shapeoko According to this?
  2. How are you initializing the Shapeoko? This is important as you CANNOT change the endmill without selecting the “New Tool” operation within CM before starting a new job.
1 Like

I’m using Carbide Create, and setting the zero to the top of the material. And of course, I’m setting zero to the top surface.

My workflow is (from memory…hopefully this is right):
Power on
Connect to cutter
Initialize -> machine homes
Rapid to S position
Insert bit for first operation
Move to zero and zero all axes (sometimes just z, if others are where I want zero to be)
Load file
Start job
CM moves to S position and prompts for bit. I hit “resume” since the bit is already loaded.
CM does the Bitsetter thing (unnecessarily, as far as I’m concerned, but I don’t know how to avoid it).
CM moves to S position and prompts to start router, which I do.
CM moves to correct X and Y for beginning toolpath, but sometimes Z is WAY off, like half an inch too deep. It doesn’t happen every time. When it’s happened, it’s been with the 90 degree V bit. But that may be coincidence.

Tonight I’ll walk through the steps again in front of the machine, in case I missed something.

For this workflow, do not change the bit unless prompted to. If you need to change it, use the CM button to change the tool.

You should initialise the machine, let it measure the bit that’s already in the machine. Zero with that bit. Then run the job and change the bit for the job when prompted.

I think the issue is that when you initialized the machine, it probed the bitsetter with whatever bit was in the router.
Then you went to “S” and changed the bit to the first bit for your project and zeroed.
Boom. You zeroed with a bit that wasn’t the one that was measured in the bitsetter - and didn’t use the “Change Tool” function to let the bitsetter know.

Use this workflow…it works for me:

Initialize. The bitsetter will be probed with whatever bit is in the router - I try to make it the first bit that will be used - but sometimes I don’t know what it will be…so I will use whatever.

I load the job.

The first bit is on the screen. If it’s the same as the one in the router, I go ahead and zero. But if it’s a different bit, I click, “Change Tool” and put in the first bit…then I zero. Now - this MIGHT not be necessary - if I zero with the bit that was in the router and had been measured during initialization - but I haven’t tried it…so I go through the effort to switch the bit using the bitsetter and then zero.

Then I run the job. It prompts for the first bit - which, by now, I have in the router already one way or the other. I let it remeasure the bit and go.

This will work.

1 Like

The BitSetter is setting zero when initialized based on the last time the Z zero was set. For an example a job is set up that is 1/4 high and you zero on top. After that job is finished you shut down and come back later to do another job. The new job is 3/4 inch in height. The machine initializes and asks for a bit and weather you leave the original bit in or change when prompted the bit that is measured by BitSetter will zero to 1/4 inch because that was the last set zero.

The x y and Z settings are persistent over power cycles with a little asterisk. The settings are based on a homing cycle and the accuracy of the homing position. If your homing cycle is off a few thousands so will your X Y and Z settings. For most projects that is ok. When cutting the same job or using the same origins it is always a good idea to go into jog and use the rapid positions to move to the x and y positions and jog down and check your settings. It is most likely to be the same as last time but if homing was off so will your X&Y and even Z.


1 Like

^^^ My next V-carve project is to make this sign to hang over the router.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.