Is the HDM spindle grounded?

That is what I was thinking initially too. But after testing the spindle is indeed grounded.

I have also been running an ion air blower (supposed to eliminate static) pointed directly at the spindle while machining. The carbide motion crashes still occur.

In looking through the tickets, it appears that Adam is getting crashes, that are different than disconnects. “Disconnects” are popups from CM that occur when the USB device appears to go away unexpectedly.

ESD problems usually cause the computer to see the USB device as being disconnected but they rarely result in a crash in CM, only a notification popup. ESD problems are also very rare in an HDM machine.

Adams crashes, which we’re still working to troubleshoot, appear to occur in a memory allocation routine in OSX, which is likely not related to any EMI/ESD problem.

I’ve never heard of an ion blower, but I’d try again without that running, just to be safe.


Interesting. I agree that crashing wouldn’t be caused by static.

@abrackney Do you have a windows machine you can try?

I initially ran the machine on a windows laptop and that’s when this carbide motion crashing issue began. I switched to a Macbook thinking that would be better…but apparently It doesn’t make much difference.

Ok another update. Carbide sent me a new Warthog adapter and Driver board. Installed this afternoon…still getting the exact same Carbide motion crashes. Still totally random. Sometimes the gcode will complete…sometimes it gets 50%…sometimes 10%! It’s crazy. No idea what’s happening now as I was fairly sure it would be a bad board or something.

It has to be something specific to your situation. I have a pre-production one and I haven’t had a single disconnect. My HDM has the production board and adapter.

Yea I am stumped. I am going to try an older version of Carbide Motion tonight and see if that helps.

1 Like

Did you ever try another sender?

1 Like

not yet. but its on my short list of things to try next. My thought is…I can’t be the only person with a HDM who uses CM to send code. So it’s unlikely that the sender is
causing the problem. however it could be a bad install of the sender or maybe a version that doesn’t play well with the HDM. I wonder if anyone else is running CM build 579 on their HDM?

Next step is a fresh CM install, and maybe try an older version.

I’ll fix this damn machine!!! :crazy_face:

I’ve used CM exclusively.

1 Like

What are you using for your cam and what post processor? Seeing that its an issue related to memory allocation and its happened on both windows and osx with the majority of people running carbide motion here and not having this problem, Maybe something your cam software is doing to your .nc files is causing a bug in carbide motion to prop up. Universal gcode sender is very easy to setup and worth while doing so for trouble shooting.

1 Like

I havent had a CM memory issue in 5 years when they removed the size limit. This file was HUGE since it was 24" andfully 3D machined. F360 took 30 minutes to calculate the toolpaths each change. :smiley: I broke up the roughing and finishing because I only had 8 hours each day…


A potentially incomplete list of potential issues:

  • EMI — this can be caused by faulty equipment (worn carbon brushes, &c.)
  • static buildup — usually this is caused by the dust collection system no being grounded ---- anti-static/static dissipative/conductive hoses usually mitigates this
  • a wiring fault caused by a broken wire and some issue with a connector
  • a heavy load on the same circuit — typical culprit is the compressor in a refrigerator or freezer
  • a problem with the electrical system — a failing transformer in your neighborhood can cause really hard to troubleshoot issues — check w/ an electrician if you or your neighbors have compact flourescent bulbs failing prematurely

I’m using Fusion 360 for CAD and CAM. Post processor I have never changed in years (at least I don’t think) according to fusion 360 post processor just says Carbide 3d GRBL.

I’ll take another look at universal gcode sended this afternoon. Thanks Rob!

Unfortunately, the machine and spindle/VFD are apparently powered by the same fused 115V 15A(?!) power entry modules on the current production HDMs! :frowning:

I’ve never had any of the 7 Shapeoko machines I’ve ran, have separated circuits for the router/DC. I do use power conditioning power strips though.


The 110V HF spindle on the HDM is rated at 12 Amps. Even if the VFD is 90% efficient, the spindle/VFD alone could draw 12 * 1.732 / 0.9 = 23 Amps from the 15 Amp circuit.

I don’t want to jinx myself…but I may have solved my problem. Still need to do a bit more testing…but I have had the HDM running today without any crashes…first time in over a month.

What is the POSSIBLE solution you ask? Well…I installed CM 842. An old version of CM. I tried deleting and reinstalling the latest build (879?)…still crashed ( I actually tried this twice ) I happened to still have an old version of CM on another computer and after installing and running this morning, everything SEEMED to be ok.

I really hate to say this is the fix…because the CNC gods will smite me now with another crash. But…it could be a step in the right direction of figuring out what the REAL issue is.

I’m going to continue to run the machine tonight and tomorrow and see what happens.