Is this a bug with Carbide Create V7?

I have been using V6 for some time and have had no problems apart from inlay accuracy. I decided to give V7 a go, with its “Inlay Mode” and “Bottom gap”.
I designed a simple 50mm circle and used Advanced VCarve using a 1/8" mill and a 60o V Bit.
I first designed it in V6 and cut it and it worked as expected.
I then designed it in V7, saved the file, downloaded the GCode and ran it - that’s when a major problem showed up.
I had set the Z axis height to 8mm from the job (3mm probe plate and 5mm lift) as I had for the V6 version but when I ran the program, it tried to bury the Z axis through the machine waste board breaking the 1/8" bit - it had not switched the router on yet.
I raised the router up high and zeroed it then ran the program again. The Z axis moved down 48mm!! then ran the program.
I checked the GCode and this is the offending line (in bold) that V7 wrote into the GCode (doesnt do it in V6):
(Move to safe Z to avoid workholding)
It is changing coordinate source by using G53, to change to machine coordinates which is then trying to put the Z axis 5mm below its zero.

Why doesn’t it just leave it at G54 or do I have to edit the GCode every time I generate a file??

Depending on the post-processor, Carbide Create may have this movement.

It changes to the G53 work coordinate system — this is “Machine Coordinates”, and matches the origin set when homing, so the command:


lifts up to 5mm (the G21 indicates we are in metric) below where the origin was set when the machine was homed.

If you are using a controller which doesn’t support machine coordinates, or which doesn’t have home set at the top back right of travel you will need to use “Grbl” or “Basic G-code” which don’t include this command:

Thanks for the reply.
I use GRBL via GSender.
The machine can be homed to the front right corner of the board but I zero it to the centre of the work in this instance.
As I said previously, the GCode generated in V6 works fine.
I have generated more GCode via V7 and I just comment out that line with the G53 and it works fine so I’ll just continue to do that.

BTW - if you look in the top right hand corner of the picture I posted, you will see the Workspace is set to G54. I have never needed to change to G53 in all the time I have been using Carbide Create or any other program.

Which post-processor were you using previously?

Does selecting “Basic G-code” or “Grbl” under Edit | Select Post-processor generate G-code which works with your communication/control system and machine?

In both V6 and V7, GRBL is set as the post processor.
I have been using V6 with success with both UGS and GSender since I built the CNC by generating the GCode from my designs and using the above programs.
I started using V7 yesterday and have downloaded the GCode from the C2d file via the website. These are the files that have the G53 line in the code.

I should also add that I successfully use Fusion 360 and FreeCad generated GCode with UGS and GSender.

1 Like

That tool is intended for use with Carbide 3D machines and uses the Carbide 3D post-processor — in order to be able to write out G-code using the “Basic G-code” or “Grbl” post-processor you will need to purchase a license:

As I stated, if I extract the GCode from the C2d file and comment out the G53 line of code, the problem is solved so I’ll just keep doing that.

This topic was automatically closed after 30 days. New replies are no longer allowed.