Issue cutting letters - Help!

I’m engraving some small letters and they are not coming out symmetrical. As you can see the image above the upper right portion of the Y is thicker than the rest. The letters have a uniform thickness as seen in Inkscape and Carbide Create below. I don’t have the original font so I don’t have the option to convert it to a single line weight. Converting it to a single line and doing a contour with a fatter bit is my preference but I haven’t figured out how to do that yet in Inkscape.

I’ve tried inside contour and pocket tool paths. The cut depth is 0.015" and I’ve tried two different engraving bits. One with 0.4mm diameter tip and 0.2mm on the other. Both with a 20 degree include angle. Material is hard maple. Machine is XL. Amazon link below if you are curious about the bit.

Any ideas on what is happening?

Original SVG in Inkscape

Tool path view in CC

Could this be a mechanical issue? With the power on, is there any ‘slop’ if you try to move the gantry back-and-forth in the X direction?

Thank you for responding! Just checked and no slop. I’ve done several tests and it does the same on all the letters. I also rotated it 90 degrees and ran it. That time the other side of the Y was fatter. See below.

Most likely you have a mechanical issue on the X-axis which is causing lost steps — check the machine mechanically:

  • pulley set screws
  • belt tension and belt anchors
  • X-axis motor mounts

If you don’t find anything obvious to address, let us know at

1 Like

Thanks @WillAdams! I’ll check those items.

Hi @WillAdams,

No luck. The issue is also scaling with the size of the object. I scaled it up 4 times actual size in CC and ran an inside contour. See the picture and the video below. As it cuts the upper right corner of the Y it moves straight down (South) a bit before going diagonal. As a result the upper right portion and the lower stem of the Y are off. At 0:21 in the video you can see it go South before going SW to finish the Y. I’ve attached the GCode as well.

Video of cut: Font Issue - YouTube (299 Bytes)

This really looks like excessive play in X. It looks like X hesitates when movement in X starts or changes direction (like slack is taken up). I would check the set screw on the stepper motor, belts, on X. The GCode is fine, this is not software related.


Check the pully on the X axis stepper motor

Both pulley screws should be tight, and one should be over the flat of the stepper motor shaft.


I had similar issue with my nomad. Not quite solved yet (with support) but indications are it is x axis. I had the option of trying the same cut on another cnc and it came out fine so it is mechanical. I don’t have a shapeoko but maybe someone else with one can try for you, support might, and that would narrow down the possible variables


If this is play in X, the magnitude is small and could vary with different feeds and speeds . Maybe 1/16 inch or less on your cuts above. One could turn on power to the XL (router off) so the motors offer resistance to movement and manually nudge the router mount left and right while closely watching the x motor, pulleys, and belts. It you can get router mount movement right and left 1/32 or 1/16 inch with no corresponding movement in the X stepper motor pulley, you have identified the area of the problem and may be able to see the source of the problem.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.