Issue with homing after changing out my waist board

Hi Guys!

I changed out the waist board on my S3 the other day and after I put everything back together homing would not function correctly. It would start the homing procedure but it would act like the homing switches were not installed. I have checked all three switches and they are working with respect to continuity.

All I had done was disconnect the power and USB when everything was off, changed out the waist board and reconnected everything. Turned on the S3 and opened CM connected and started the homing process.

The z axis topped out and kept running stuttering on the belt. I power cycled the S3 and the same result happened. I checked the settings on the G board ( Shapeoko has homing true)

I have the new 2.4 board version and have been running without ANY problems since the install of that and a newer computer a few weeks ago. I have tried reinstalling CM and checked everything I can think of.

I’m at a loss as to what to do next next.

I suspect you have a bad switch (or broken wire?)

Try releasing the tension on the belts so that the machine won’t move, then swap the connectors for the homing switches around and try triggering (say) the X-axis switch connected to the Z-axis connection on the board.

Hey Will!

I will give that a try here pretty quick, though I did put a VOM to the molex connector that holds all of the wires for the switches. I just got through swopping out the control board for the older one that was replaced with the same problem so Im inclined to suspect switches as well so I will focus my efforts their.

All the switches checked out…;

The problem was I had the router set a smidgen to high and it was hitting the switch plate and keeping it from hitting the limit switch.

Face Palm!