Issue with shapeoko 3 not following code properly (I think)


(Neil Ferreri) #21

I wouldn’t replace it unless you know it’s damaged. As has been mentioned, check the belt tension and make sure the pulley is not slipping on the motor shaft.


(david lewis) #22

I have this problem randomly as well. I use my S3XL for production, and its used heavily. I find that I can cut the same file 10 times in a row and its perfect, then on the 11th it does random things. Yesterday it ruined 3 projects and cut 5 fine…

I’m always making sure the screws are tight everything is solid etc as I’ve had it ruin a very large job before so I’m careful. I used new bits that are sharp etc.

I also home the CNC between jobs and even reset carbide motion after a couple of jobs in case thats the problem. It is always the same issues. Either the Z axis doesn’t retract enough moving from start point to start point causing the router to randomly cut where is shouldn’t, or it just stops and tells me its lost connectivity with the CNC.

I use vcarve for software and carbide motion 3…

David


(William Adams) #23

Please update to CM4 if possible — I’m going to ask if we have some sort of debugging version of CM which might help in this.


(John) #24

I have CM4 I also checked to make sure i had the newest one.


(John) #25

Will,

Did you find out if there is a way to debug?


(William Adams) #26

Unfortunately, we don’t have a debugging version.

Please send in any problem files which have repeatable problems with a full description of your setup and how you’re running your files to support@carbide3d.com if you believe the problem is in Carbide Motion.

If you believe it’s in Grbl, then check in w/ @chamnit on github.


(Dean Powell) #27

Last year I was having the same issue sporadically and decided it was something causing the Z carriage to misstep. On one particular project that had to cut deep pockets it messed up Three times in a row but wasn’t in the same spot, but close. I don’t have dust collection and was getting good chips like I wanted. I thought maybe the flying chips were getting thrown into the area where the Z belt is and perhaps getting between the bottom pulls and the Z belt. I put son tape, to act as a shield at the top and bottom of my Z plate and haven’t experienced that problem since. I did cut the problem pattern several times after applying tape. I keep the tape shields on there on there as for me it seems to alleviate that issue.


(John) #28

That’s funny that you say that as I was just coming to post that I believed the issue to be the dust/chips getting into the v-wheels. Does anyone know of a solution to this issue? I see it being an issue on my other axis as well due to no dust collection.


(Layne Mims) #29

I had the same problem, it was the z axis losing steps. it seemed to happen on rapids like at the start of a run. I starting changing the z axis accel and max speed. I’ve slowed it down and accel too and now i dont have that trouble anymore.

I tested mine by indexing all connections in the z axis. put sharpie mark on everything. now i could tell if pull slipped or what. after zero, i raised the z axis 2 inches and zeroed again.

I then set a lase with horizontal across the bottom of the collet. I then ran a file and watched as it would just keep getting deeper and deeper. if you pause, you can read the z value and compare to the difference in z laser. the 1st time i ran it, it was losing a lot of steps. by line 7000 in code, it was about 1/4 deep. It looked to run fine, but just kept getting deeper.

I then changed the settings, by setting $112=xxx for z rate, and $122=xxx for z accel

i’ve not had any problems on x and y axis, just z axis. I assume it was due to the weight of the router vs springs, vs speed run. with high accel, it hit the high max speed very fast. i’m assuming that is when i lost steps. play with it with the laser test and see how it runs. Mine is slower, but not a lot, but is much smoother running.

email if you have any questions, or need help finding defaults in your system. $$ is the command to write your defaults to the log file. when looking at the log file, hit stop and make sure it is not currently writing and scroll down.

when you enter a setting in MDI, it is saved in the controller until you reset defaults(with send default data, after selecting your shapeoko). If you reset in the future, you will have to reset the changes. I’m not sure how to access the defaults in the controller.

Layne Mims
layne.mims@gmail.com


(system) closed #30

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.