Issue with shapeoko 3 not following code properly (I think)

(John) #1

Hi, All

The issue I’m having is i created a maze in Aspire 9.0 and exported the tool path with the shapeoko 3 post processor (inch version). Everything looks good on the preview in Aspire. When I run it in Carbide Motion my Z axis is not going all the way up to clear the material as it is traveling. I attached some pics. Let me know if anyone has seen this and what I should maybe check.

(William Adams) #2

If things preview correctly usually this sort of problem is mechanical, please see:

It’s also possible you have a belt with a flaw or some sort of damage.

(mikep) #3

I have seen this too, it’s a bug in GRBL, and I don’t know what triggers it. It’s really rare (I’ve only seen it 2 or three time), and I have run the same job twice and not had it happen on the second run. Have you tried to run this a second time?

(Jesse Glessner) #4

Another thing you might check on is in Aspire itself.
I had this same thing happen recently myself. SO . . . . .

  1. IN ASPIRE: Click on the Tool Paths Icon
  2. Select a Tool Path
  3. You should see a “Material Setup” area at the top.
  4. Click on the “Set” button
  5. This allows you to set several parameters concerning the material/machine interaction
  6. Pull Slider Bar at right side all the way down.
    Cursor down to last box for inputs.
  7. I believe, but am not 100% sure that you want to set your “Z Gap above material” to a larger gap. I just checked a downloaded file done by a PRO and it reads 1.8

Since your piece is ruined you might try doing the above and then repositioning you material off-set by an inch or two and make another run to see what happens.

(John) #5

Thanks for the reply. I checked those settings and eveything looks ok to me. I attached a pic. Let me know if you see anything I missed.

(Aaron Wunderlich) #6

Drop your gcode file here and see if it replicates. Just another tool to try out.

(Jesse Glessner) #7

The figure you have in there, 0.8, should clear any “Z” hops from cut to cut.

IF that was already in your file then it is some other problem.
Do you have static? Is your vacuum possibly causing interruptions (static or switching) in your system? You might check those out.

(John) #8

So checked eveything and it all seemed fine. Ran it again and all was good. It got up to almost 50% and the z axis chattered for a second then the x and y moved a little and the z plunged like an inch deep. I don’t have a vacuum on it yet so no static there. Could the dust build up cause this? Attached are a few pics.

(William Adams) #9

MDF will expand and fill a slot / pocket — I’d suspect loose belt tension or some mechanical problem if this path doesn’t show up in a preview and there’s no reason for it to happen there (e.g., the too many decimals problem of MakerCAM).

(mikep) #10

I’ve seen exactly this problem cutting paths generated by both fusion360, and meshcam, I’m 99.999% sure this isn’t static, and it’s not post related.

(John) #11

What do you think it might be. I don’t think it mechanical. I checked everything and all seems fine. Belts are tight and it runs for a good bit of time before it jacks up. It it something with my board not controlling properly?

(mikep) #12

It’s a GRBL bug. Like any other software, it does have bugs, and this is one. It doesn’t show up in simulation (as you showed too), and after digging around in the gcode for my instances, it’s just plain not there. That leaves GRBL. It fails to retract all the way to the retract plane in this weird case. Here’s the last time I saw it: . Note the weird cut across the “t” - seemed a little too appropriate for the sign, so I left it on that one.

(William Adams) #13

Anyone who has files which exhibit such behavior should, if possible test them with a different communication / control program to see if it’s the comm program or Grbl — once you work out which it is, please send it in to the appropriate folks.

(mikep) #14

That’s the problem, really…it doesn’t even reproduce using the same sender. That it won’t do it in a second program doesn’t mean much. If it did it every time with a given sender, then you’d be onto something.

(Neil Ferreri) #15

Does the Z axis recover to correct height after this? If it does, that’s weird. If it does not, I’m with @WillAdams and would say it’s mechanical (possibly electrical).

(John) #16

I stopped it when it plunged, but when i move everything around after it all works fine. Also, I would think that it would be pretty obvious if there was a mechanical issue. Belts are all tight and teeth are fine. Gantry is tight and all the v wheels are tight. What kind of mechanical issue would cause the Z to plunge and inch or more?

(Dan Nelson) #17

How high does it retract while it does the shake before plunge? Does it retract so high that you reach the mechanical limit of the Z? Is the shaking you describe possibly come from the machine reaching mechanical limits, slipping some belt teeth? May be something else, but the only time I’ve had the “shake and plunge” is when the above happens. The homing switches are not limit switches, if the machine does the shake and skips teeth it no longer knows where Z zero is and will bury your end mill every time. I ruined some nice wood before figuring that out. Just another thought.


(Neil Ferreri) #18

@DanoInTx I first thought the same, but I’d expect that to happen early in the program, not at a random spot halfway through.
@littletim777 Not necessarily an “issue”. If Z steps are lost due to any number of things, you could see something like that. What endmill are you using and what cut settings?

(John) #19

Here is the tool I’m using. Also, where can I get a Z belt? I don’t see anything wrong but I’ll replace it just Incase. I’m not sure if it was hitting the limit switch I was at my comp when it happens and hit pause when it did it.

(Stuart) #20

it has been mentioned, but just wanted to confirm that you have pulled the set screws out of the Z-Axis pulley, confirmed one of the two holes lines up with the flat spot on the Stepper shaft, then loctite’d them in.

It screams loose set screw to me, I use aspire heavily too and have never had anything like this out of it