Issues with Carbide Create Build 451

I just tried cutting a design using Build 451 for the first time and had major issues with the results on my machine. Everything looked OK in the preview simulation (although the operation times looked unusually long), but when I ran the job on my machine, on the first pass it plunged the bit past the original depth I had specified, cut the pocket, and then kept retracing its path for another 10 times or so - it’s hard to tell if it’s changing depth on these passes as I have a dust boot installed. It also completely ignored the tabs so it destroyed the piece it was cutting when it broke loose.

I tried uninstalling it and installing an earlier version (431), but even after uninstalling and manually removing the Carbide folders I’m getting some strange “NaN” information where the feeds and speeds info should be.

I wanted to post and see if anyone else has had problems with Build 451. I just created the same program on build 433 (different PC) and it works just fine.

do you have a c2d or .nc file for us to take a peek with?

Here’s the c2d file and the Gcode file that I was using in Carbide Motion

Spring_2020-02-02_Dog_Step_Stool_Short_Half-Inch_ply_1.c2d (156.3 KB)

Spring_2020-02-02_Dog_Step_Stool_Short_Half-Inch_Ply_2.nc (649.6 KB)

  • retract height 1/2" – good; avoiding that pitfal
  • speed is a bit on the high side (it seems to be about 2x faster than what I normally run with!)
  • DOC seems to be about 0.05" which is fine agin for bit 201

The feeds and speeds were all calculated by Create. I didn’t change any of the settings. The results from the Gcode seem to differ from what the intent was.in Create. And the one I’m cutting now from Build 433 is working great and cut the whole operation time in half.

NAN = Not A Number. Something you really don’t want to see as it obviously means the software was expecting a number and didn’t get one…

2 Likes

My big concern is 00- 0.55" deep is a deep/narrow slot — add geometry around to cut as a pocket — as always, should you have issues, feel free to contact us at support@carbide3d.com

The file previews fine in CAMotics with G-Code from CC451:

When switching to an older version, got a bunch of errors from the change in the toolpathing:

Filling some quick values and exporting G-Code seems to work:

I suspect to get the older version to work you’d have to reinstall it and then work up a script to switch between two different preferences folders.

1 Like

Wow, thanks for the screenshots and info. I will download Camotics and use that to see if there are any other issues. It could very well be user error, I will re-zero everything and try running it again this weekend.

One question: Does Create calculate feeds and speeds differently for a pocket vs a slot?

Thanks again!

No, Carbide Create uses the specified feeds and speeds without consideration for toolpath — that’s why it’s important to not have excessive tooling engagement.