Issues with pocket toolpath

Ok I have been trying to wrap my head around this issue for a week and can’t figure it out.

I am doing an epoxy pour sign. I set up tool paths to carve out the blue color pour and it worked out fine. When I try to pocket out the white inlay pour, Carbide Create does not do a pocket in middle of N and Y and I can not figure out why.

This is what I am trying to achieve.

I run the blue cutout and get this.

So after I pour the blue, I have tried for the life of me to pocket out the white and it won’t do it in preview of CC. Using pro version build 743. I get this…

Any ideas what I may be doing wrong or is this software glitch? Pretty sure I am missing something but can’t figure it out.

It looks like the part left untouched is an open vector.


Then how come it carved the blue pour / inverse? I don’t see any open nodes or vectors and have verified this in lightburn with SVG file.

Can you post the file?

1 Like

NYY Hat Epoxy issue.c2d (480 KB)

Even just upgraded to latest build and still same issue.

Trying to peel this apart vector by vector. Things look good until you start adding the vectors of the hat internals, that’s when these pockets start falling apart. Still thinking about this one…

1 Like

Something definitely broken in the software. I started simplifying the project to make a ‘minimal case’, and now the program is stuck ‘Calculating toolpaths’. It’s stuck on one that was working until I started deleting nodes on some vectors, now it’s broken.

I simplified the design like so. It’s broken as is. If the high-lighted node is deleted, it works. CC757.

NYY Simplyfied.c2d (3.6 MB)


If you modify these 2 areas to 0.130 wide to allow the 1/8" tool, it seems to work.
I don’t see anything wrong with the 3 vectors just below that spot that were getting cut through


Even moving the high-lighted node will fix things. I created a new path using a 1/32" bit to experiment with. Apparently, once that node is more than 1/8" away from that line nearby, it works, even though I am not using a 1/8" bit.

that doesn’t make sense because I tried it with 1/32th bit.

Even if “moving” it solves this particular case…isn’t it a software flaw? It should still pocket, just leave material…so then could use rest machining.

1 Like

I saw an 1/8" bit listed, but it’s a custom tool that I don’t have so I can’t look at the parameters.

Jim, yes I agree it’s a bug. Unless someone at Carbide can find a vector causing issues.

1 Like

I have tried all standard Carbide bits from 1/8 down to 1/32 for simulation purposes. It still should pocket regardless if tool is too big. Then could use rest machining to clean up. But software isn’t working like that in this case. I’m just baffled.

Thanks. Just did ‘inside’ offset and fixed the issue (even though I believe there is software glitch and have emailed Carbide support). Gracious.

1 Like

Teamwork makes the dreamwork!

Awesome debug everyone.

1 Like

I was able to make this work as noted on support by simplifying the toolpaths and adjusting the design so that the tool would be admitted into the narrow gaps:

Even when the bit fits, it still can manifest:

This is using a 1/32" bit.

That doesn’t seem to be the case with the simplified geometry which was sent via e-mail from support.

This happens with the C2D I attached above. Moving or deleting the high-lighted node fixes the problem.

Thanks for the help and response on this. While it is a solution and fix…temporary…is there a software issue? Is there a technical answer on why this happened?

Shouldn’t this been able to be run with larger bit .125 bit and then use rest machining to with smaller .0625" bit to get inside the closer lines? Sadly this not the first project I have had this happen with.

This solution works and fixes the issue, but having to delete and “hope” to remember offsets and settings in setting up tool paths for this if I come back to make it months later will be problematic.