Issues with Tool Paths

I just got my Shapeoko 4 XL up and running but am having issues with cutting depths. I set my material thickness at .75, then set my Contour Cut for 1/4". It cut way past the 1/4" and continued to the 3/4" material thickness. Prior to that cut, I used a piece of scrap wood under the material as a safety net. I set the Contour cut depth to 3/4" and it exceeded the material. between my stock and the scrap piece underneath (1/4" plywood) the cut still went into my MDF Strip and missed catching my Hybrid Extrusions by 1/16". The total depth it cut was around 1 1/8".
I have been in contact with Carbide 3d Support and they helped redo the settings but it is still not cutting correct. Is this operator error, a settings issue, or something else I am not aware of?
I have the Shapeoko 4 XL. No attachment (Bit Setter, etc…). My Travel Dimensions are X:865.000, Y:455.000, and Z:95.00. After changing setting with the Support Staff, these numbers remained the same.

If you jog the Z one inch, does it actually move one inch?

1 Like

I’m pretty new with this but have wrestled some Z axis issues but nothing as severe as yours. Couple things to sanity check. First to ask the stupid question: how are you zeroing the Z since you have no attachments? Make sure the Z zero matches what you set in the CAD software (for Carbide Create under Setup → Zero Height, choose top if you are zeroing to the top of your stock or bottom if you are zeroing to your spoilboard.

When the cut job starts, does it start at the top of the stock and take a very small amount off or does it plunge deep? If deep, your Z zero is off. It should only be taking like .04 inches per pass. (assuming the default endmill settings)

if all this seems to be right, I’d try this experiment, jog and set your zero on top of your stock. Start running it. After you are sure it has cut too far, pause, then stop the job. Then after the machine has reset, jog back out to your stock and see where it thinks the Z zero is. That might help support determine whether you it’s user error in they way you use your CAD software or something else.

Hope some of this helps

2 Likes

Even at the fastest rate (speed setting) it does not move 1 inch. If I increase the increment speed to the highest setting (fast), it moves by 1/4" increments.

So move it 1/4" four times. Use a ruler for reference. Does it actually move one inch when you tell it to?
If not, we can adjust the settings. If it does, we go to the next thing.

There is no such thing as a stupid question in my eyes. I use the paper method.
When the job begins, it moves to the first cut and removes 1/8" and continues the cut in 1/8" increments.
I will run a test piece and note the measurements to give to the Support Rep as you suggest.
Thank you for the information.

Yes…x4 moves 1".
I also measured from my last test piece to see if the cut matched my job set up. The first cut was set up for a 1/4" Pocket Cut which measured at 1/4" as it should have been. The second cut, the outline Contour Cut, was set at the same 1/4" however, this cut continued to 3/4".
When I have it set to the material thickness of 3/4", the Contour Cut will go through the material, through the MDF, and hit my Hybrid Extrusions.
???
I assume there is something that I am doing improperly or there is a setting somewhere that is messed up that I need to change.
I appreciate the help and input

Which Z-axis do you have?

Go to Carbide Motion, open the Log window, go to MDI and send $$ — what shows for $102?

It sounds as if you have a Z-Plus, but have configured for a belt-drive (that would be 5 times the motion (40 steps/mm vice 200).

It shows $102=200.000 in the log file

Where are you setting your Z-zero?
How are you setting your Z-zero?
Can you share the gcode for the project you had issues with?

1 Like

Please contact support@carbide3d.com and let them know that — if it’s not some misunderstanding in how you’re setting up your jobs it could be a bad stepper driver or some sort of wiring issue.

Are you deliberately setting your depth per cut at 1/8"? That’s pretty deep. The default for Depth per Pass for any of the preconfigured endmills is typically on the order of 0.04 in per pass. If Carbide Create says you’re supposed to be cutting 0.04 in per pass and you are really cutting .125 in per pass, then something is wrong in how the Z is being interpreted by the S4

1 Like