IT has arrived!

Now the fun begins (SO3 XXL)…

Godspeed my friend :slight_smile:

Have already run into what appears to be a manufacturing omission. Shouldn’t there be threaded inserts on the bottom of ALL holes in the bottom wasteboard supports? Otherwise, what are you supposed to thread the screws into?!

The part in your picture needs to connect to the U shaped part(s) (two of them front and rear of machine) which is the part with the threaded inserts.


Well there ya go! Don’t I feel like an idiot. Thanks!!!

Need to update the documentation in regards to the Z-Axis assembly, more specifically when it comes to installing the router mounting bracket. Nowhere does it mention installing the bracket. I now have to take the z-axis plate off, again, to mount the router bracket.

Should also update to show limit switch wire routing thru drag chain. I didn’t get how to route it initially, so had to pull apart the drag chain a few times.

So where is the ‘squaring your machine’ section in the online documentation?

Ok, so it’s finally all together. Now trying to just poke around in Carbide Motion. Upon fireup, rec’d numerous GRBL errors. Restarted and seems to work for the most part. Notice some jittery jogs, using version 361. In SETTINGS, turned #1005 (Shapeoko has homing) to TRUE and then when I go to JOG, it says, Click to Begin Homing. Click then get a “GRBL Error: Setting Disabled” Then CM says, Homing Machine but nothing happens and CM seems to lock up. If I turn that off, then I can jog, but this does have limit switches which is for homing, right? Also, limit switches seem to have no effect.

For squaring see:

Mine didn’t take the ‘has homing’ setting the first two times I tried it. Third time was the charm and I double checked the setting had changed on the settings tab. Homing has worked okay since.

@chikn post your settings on here so it can be looked over,im sure with more info someone will help

After reading a couple posts about the limit switches, saw a few mention they might need to be prodded a bit to get them to work. I then manually pushed them several times and they seemed to have come alive. Homing cycle now works, but seems to be a bit hit and miss. More specifically, when the cycle goes along, the x-axis typically stops short and just hangs there. I then bump the switch and it then continues along, slowly, until it finds the stop. In a couple cases, it was several inches short of the RH rail.

I don’t know about how long everyone else takes to assemble these, but I’d say I put in a good 8-10 hours from unboxing to completing the “Hello World” step. Granted, I had to redo a few things, in some cases several times such as running the wires cuz I would forget I had to run this wire thru the drag chain and so on. This is my first CNC build but I have build lots of stuff.

How do I go about posting my settings?

A few pix always make a thread better :grin:

Looking good chikn,In carbide motion open the log and in the mdi type $$ and enter,the settings will then be in the log,should be able to copy/paste at that point

Turned on the machine today and nothing. Homing didn’t work at first. Had to disable (turn to false) the homing in CM settings. Then Homing worked.

Here’s what the $$ produced.

Test Waiting…
___________$$ ___________
$0=10 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=6 (dir port invert mask:00000110)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=255 (status report mask:11111111)
$11=0.020 (junction deviation, mm)
$12=0.010 (arc tolerance, mm)
$13=0 (report inches, bool)
$14=1 (auto start, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=1 (homing cycle, bool)
$23=0 (homing dir invert mask:00000000)
$24=100.000 (homing feed, mm/min)
$25=1000.000 (homing seek, mm/min)
$26=25 (homing debounce, msec)
$27=5.000 (homing pull-off, mm)
$100=40.000 (x, step/mm)
$101=40.000 (y, step/mm)
$102=40.000 (z, step/mm)
$110=5000.000 (x max rate, mm/min)
$111=5000.000 (y max rate, mm/min)
$112=5000.000 (z max rate, mm/min)
$120=400.000 (x accel, mm/sec^2)
$121=400.000 (y accel, mm/sec^2)
$122=400.000 (z accel, mm/sec^2)
$130=425.000 (x max travel, mm)
$131=465.000 (y max travel, mm)
$132=80.000 (z max travel, mm)
___________N0 G4P0.05 ___________
___________$# ___________
___________$G ___________
[G0 G54 G17 G21 G90 G94 M0 M5 M9 T0 F0. S0.]

set 130/131 to 850.00 $130=850.00/$131=850.00

you may want to look into $20/$21 once you get going aswell

Regarding hard and soft limits, do you just enable them (turning 0 to a 1 I presume) and that is it or do you also provide add’l values in another code?

yes 1 will enable and 0 will disable,im not sure about another value for it

What is the difference between the hard and soft limits? I have enabled them both. One thing that I don’t like is it only seems to affect the negative Z axis, is if I hit that, it says the limit switch has been hit then I have to do a homing cycle to be able to do anything again. Perhaps this is by design, but I would rather it simple tell me and then go about it’s business rather than force another homing cycle.