Job Increments Change to MM at End of Job

I’ve been seeing an issue lately on my XXL where a job will run fine, but when the job is complete I go to jog the spindle out of the way, and the jog increments seem to have changed to MM. I’m using UGS 1.09 stable build. If i issue a G20 command I can start jogging normally in inches again. I’m using the Shapeoko Inches PP in Vectric VCarve Pro 9.0 (I’ve seen this issue in 8.5 prior to upgrade). I’ve checked the gcode and cannot see anywhere where a G21 is being issued, and I find it odd that the job runs fine and finishes properly. Normally before I start the next toolpath I go ahead and restart the controller, restart UGS and rehome just to make sure everything is reset.

My controller was swapped out for EMI issues last year. I have I believe a 2.3 board. Big capacitor, but still has the E-stop pins. I’ve noticed that the problem seems to happen more often when cutting acrylic that when cutting wood, so static may be a factor.

Any ideas?

I believe you need to send a $13=1 command. Grbl I believe is defaulted to report in MM. Ray

$13 is set to 1, and everything works in inches. It is only at the end of a job that ran correctly, in inches, the job completes, the spindle goes back to my job zero location and stops. When I go to jog it only moves a mm at a time instead of the inch it is set for.

Please check the log window — I suspect that you’ll see that Carbide Motion is sending G21 — please file this as a bug report at

I’m not using CM. Using UGS, and do not see any G21 commands in the gcode or in the console. I’m going to experiment doing the same cut without the dust collector running. I also ordered some of the USB cables you have recommended on other threads to see if that makes any difference. I’m already using a USB isolator. I had this problem when using my old laptop and now still seeing it with the newer desktop I’m using in the shop, so it does not seem to be a PC/USB port issue. The Dewault router power cord runs out the opposite side of the enclosure, not near the drag chain. So I will see if I can isolate the issue more. I have seen this when cutting wood, but it is happening every time I cut on acrylic, so I am suspecting static may be a culprit here.

@dtilton71 the nightly version of UGS handles this a lot better than v1.0.9, it will issue the G20/G21 for each jog movement.

1 Like

Thanks Will. I have 2.0, but have not used it much. I will give that a go (haven’t taken the time to get used to the new layout). I want to use the platform edition as well. But I will try 2.0 classic and see if that helps. Thanks for the work you do on UGS.

I moved to UGS 2.0 and I believe the issue with changing to mm at the end of a job may be fixed, but now when a job ends, all of my machine controls are grayed out. The job ends fine, spindle goes back to job zero location, popup say job has completed. But now I can’t jog at all. I have to restart UGS, which then requires a rehome befre I can change the bit. And the last time I did this it lost my job zero settings. See screenshot.

I don’t know why it is throwing a G21 in that last line. Where is that coming from? I have UGS set to inches and $13=1.

1 Like

I fixed that bug recently and neglected to update the stable build to include it. If you update to the July 28 stable build the disabled controls should be fixed.

That last line is GRBLs current internal state, it’s being displayed because after a soft reset UGS sends $$ and $G. That might have happened if you tried to stop/cancel the job after the controls remained disabled. GRBL is still honoring $13=1 since the machine location is in inches. UGS temporarily changes the units to your preference, then switches it back to avoid altering the internal state. So it is normal to see G21 here.

1 Like

Would that be the 2.0 Somewhat Stable Build or the 1.0.9 Stable build?

The 2.0 Somewhat Stable™ build

1 Like

Will - In the 2.0 Stable build, if I click Pause to pause a job, the machine controls are grayed out. Is that the expected behavior? I know in the previous release the controls were grayed out when a job was cancelled and that is fixed, but now the machine controls are grayed out if I pause. So if I see an issue and need to pause and move a clamp or in this case remove my dust shoe, I can’t because the controls are grayed out.

Yes, that is expected. Pause puts grbl in a special state where the only thing you can do is resume. So in UGS when you click pause everything interacting with the controller should be disabled except the resume button.

Thanks. So there is really no way to make an adjustment once you have started the carve if the cutter is in the way. Good to know. Usually not a problem, but in this case the front of my Suckit dust shoe was going to hit a clamp. So i needed to remove the dust show. Luckily it was right at the beginning of the profile cut, so I just cancelled the job, made a separate toolpath for the profile cut, removed the show, and started the new toolpath.