Jogging Issues in CM

I’m having issues with being able to jog the machine. I can only use the rapid positions but nothing else. I don’t receive any errors. It’s goes through the homing cycle just fine beforehand. I just built assembled everything yesterday. Any ideas to what’s causing this?


That’s peculiar.

Do the rapid positions work as expected (in the sense that they bring the router at the expected location)?

Can you go in the Settings menu in CM, click Open Log Window, make sure “Hide status reports” is checked, leave that window open, go back to CM and try to jog. Does anything show up there?
Clicking on the jog buttons should produce “$J=…” commands to the machine.

Have you increased the jogging speed increment beyond the initial default which results in almost imperceptible movement?


Will may be on to something. I have noticed in the newer versions of CM that the default increment is the smallest unit by default. If you increase it to fast or a larger number you should move. I have seen some posts in the past with touch screens that things did not work as thought but that was an issue with the touch screen and not the Shapeoko. So be sure to use your mouse and not a touch screen to check it out.

1 Like

I didn’t notice it until I read this but when I would go to jog the machine no matter the speed setting it would set it to 0 when I attempted to jog then go back to whatever speed I set it to when I stopped. I reinstalled CM and it solved the issue. I was able to do the hello world and do a first cut, ran perfectly.

Thanks for the help!

1 Like

Mine will occasionally not jog either, I will have to restart the software and then I don’t have an issue. It’s not due to the increment either, because I will have it set to fast and it won’t move at all. But a restart does the trick for me