Latest Build 629 on Windows

Ive been using build 520 for a while but today decided to try the latest version of CC build 629.
When trying to run build 629 i get the start up screen with “[NewFile] - Carbide Create, Build 629” written in the top left of the screen but nothing else… The rest of the screen is blank.
Im running the windows version with Windows 11 on a Lenovo all in one system which has a AMD Radeon graphics card… Does anyone know how to resolve my issue.
A bit of an update… Ive just installed the latest Beta version and that seems to work although i havent really tried it yet

Have you loaded the DLLs from:

Microsoft Download Center

Visual C++ Redistributable for Visual Studio 2015

The Visual C++ Redistributable Packages install run-time components that are required to run C++ applications built using Visual Studio 2015.

For more recent versions try: Latest supported Visual C++ Redistributable downloads | Microsoft Docs — note that it may be necessary to install both x86 and 64-bit versions.

1 Like

I cant say i have…Im not that savvy with computers but ill give it a go

It is part of the download process when loading. If you stop it, it will not load. Even if you loaded it this morning, the program needs to see that you just downloaded it.

That’s unlikely to be the problem, if those are missing the program doesn’t run AT ALL.

Rendering problems may be an issue with crappy video drivers and the OpenGL version they support, but since yours are integrated I don’t know if there’s a way to find better ones.

You can find out what version of OpenGL your machine supports but you have to install a utility.
This one worked for me:

Under the ‘OpenGL’ tab, look for ‘GL_VERSION’ in the first box.

1 Like

Cool utility. I tried it out. Very nice. Thanks for the link!

Like ive mentioned ive run the beta version and after trying it seem to run with no issues so dont know why theres an issue with 629.
Think ill stick to the beta for now

Lenovo ideacentre AIO 3
OPEN GL 26.20

Bit more of an update, After using the Beta version as far as im aware everything works except when i go to show simulation… all i get is a white screen.
Any ideas

Please see if there is an update for the video and OpenGL drivers.

1 Like

That looks like a 10th gen i5-10400T, so rather recent (much more so than the i5-5200U I run CC on). The 625 is from late 2019 so also recent. From a very quick perusal Lenovo’s driver download is several years old, the one direct from AMD is version 22.2.3 dated 2/24/22, probably isn’t at all related to your “opengl 26.20”, the latest opengl version seems to be 4.6 from 2017. The usual warning is that Lenovo may have made changes that aren’t reflected in the AMD driver. I couldn’t find what version of OpenGL that driver supports but it would be exceedingly odd if a current production video card/chip didn’t support much higher than V2.1. You could check this link and see if it suits your needs.

1 Like

Ive downloaded the latest driver pack from AMD and its still not working… Also tried the very latest beta build 648 and still no joy… Using Build 520 and its working perfectly

One thing ive found is that if i create a file in beta build 648 i cant view it in the simulator but if i save it and then open the file in build 520 i can view the simulation with no issues

Please try View | Use ANGLE Rendering:

if that doesn’t work, let us know at

1 Like

Looks like youve cracked it… Using Angle rendering works …
Thanks a lot

This topic was automatically closed after 30 days. New replies are no longer allowed.