Lightburn hindering bitzero v2

Hello everyone,
I’ve searched through the history and haven’t found a solution to my current issue. I recently installed a Jtech laser witch I run lightburn. I created 2 macros, one for the laser and one to return to CNC. That Macro reads:
G10 L2 P1 X0 Y0
$10=255
$32=0
Everything works fine except my Bitzero V2. It will not get a successful probe. Is there a macro command that I am missing? I disconnected, reset and all the sharp shooting steps I would take prior to using lightburn with no success.

ANy assistance would be greatly appreciated.

Paul

I have a JTech laser as well, with no issues - but I use the V1 Bitzero - I can’t imagine anything in those macros would be doing anything…I think they’re pretty innocuous. Everything else works fine in CNC mode?

I will mention, I had to add a “$X” to the first line of my UseCNC and UseLaser macros (in Lightburn), to clear a block that popped up due to a change in a recent version of Motion and Lightburn (I don’t remember which caused the issue). It’s a harmless command, but if it’s needed and you don’t have it there, the rest of the macro will not run…so you’re better off putting it in as the first line of both macros.

What do you mean exactly?

Initially the machine would only do rapid placement, such as center, center front etc. when I went in to do smaller movements it wouldn’t move at all until I put in the CNC macro tab. So now the machine works fine except it will not probe correctly. The pins for the laser and the bit zero are right next to each other so I’m hoping its not a physical issue.

When the bit lowers unto the bit zero the light will turn green but the machine does not stop and continues to push the bit into the bit zero until it stops. I then get the pop up window that states unsuccessful probe and then the machine will have to be reconnected.

Can you get a picture of the connection at the board? Sounds like a wiring issue.



Do you have a bitsetter? If your bitsetter plate is touching the spindle connection(the little magnetic part) or if the bitsetter pin on your board is grounded it could cause this behavior I believe.

No I only have the Bitzero v2

To determine if the probe signal from the bitzero makes its way to the controller correctly (which apparently it doesn’t), open Carbide Motion, go to the Settings page, in the pane where the “GRBL Active input pins” section appears, and manually trigger the bitzero (touching the probe with the clip). Does it read “PROBE” then ? If not, but the LED on the bitzero still works as expected, chances are that the probe signal/wire between the bitsetter and the controller is broken somewhere along the path.

Does your BitZero problem still occur if you temporarily unplug the Jtech laser cable at the Shapeoko controller side ?

It does not change the “GRBL Active input pins”

As Neil Said it’s a wiring issue then. Maybe while plugging the laser connector you impacted the bitzero connector next to it on the controller board. Try re-seating it/wiggling it and repeat the manual triggering of the probe until you do see “probe” showing in CM settings screen? If it show up even intermittently, you’ll know it’s a bad connection. You should contact support at this point too.

Can the probe plug into the probe pins on the other headers? I’m not familiar with that version of the PCB.

Not sure but i will give it a try at the shop tomorrow