Limit Switch hit error message

I got a “Limit switch hit” message, and now I can’t do anything with the machine. How do I get it to move off the limit switch?

1 Like

Turn everything off. Unplug the usb cable. Reach in and move the carriage off the limit switches.

Now plug the usb cable back in and turn the power back on. Should be ok now.


Didn’t think it would be that simple… LOL Thanks Mike!

You should be able to reset by issuing a $x code and move away from your limit switch instead of shutting your machine down which will caus you to use your homing settings.

You don’t lose part zero locations by power cycling the box. Home locations are set off the limit switches. When you power cycle the box and >then home<, it will still know where the part zero is. If you don’t home after moving the carriage like that, yes, part zero will be messed up.

We are saying the same thing i think. Turn it off, lose your home position unless you re-home. $X move away from limit switch and your home stays intact and you dont have to cycle your power. Or at least that is how mine works but then again I put hall effect sensors on every axis both positive and negative so I may be observing something different than others.

Need some additional help with this.

Just got this error with my Nomad. I’ve tried to find a diagram of the machine so I can move the carriage off the limit switches, but I just don’t know what that means. My carriage is about 1/4 of the way away from the wall of my machine, and it won’t budge.

Any help would be appreciated. Thanks.

Move the parts toward the center of the machine — it requires a bit of effort, which can be disconcerting at first, but just give it a firm push/pull and they’ll move enough to get off the switches to allow you to begin.

Thanks Will,

Ok, I was able to move the carriage. Did that after unplugging the usb cable and powering off. Got everything back together and started my program again. Still got the limit switch error.

I’m starting to wonder if it’s my file, although it started to run and then communication went offline between the machine and the computer. So I restarted everything and that’s when I got the first limit switch error.

Any other suggestions?

1 Like

Kathleen, send us a video of the error to and we’ll take a look, then we’ll setup a call to troubleshoot if we can’t figure it out from the vid.


Thanks Jorge, I will do that.

Ok, my apologies to all and thanks for your help.

My husband did some additional troubleshooting. He asked if I had moved the Z axis, I had not. Disconnected everything per mikep’s advice. Followed WillAdam’s advice knowing things are a bit tough to move. Moved the horizontal first, then the vertical. Plugged everything back in. (At one point I even powered down my lap top and restarted).

Moment of truth. Fired up Motion (also got the latest upgrade) and IT WORKED!!! Yahoo.

Thank you.


Hi Jorge

It would be nice to see a way to fix this without restarting one day. Or a quick fix to help eliminate confusion would be if the error message told you to restart the machine.

To that end @1st_Kiwi_Nomad and @Jorge , replace the generic Limit Switch Error dialog with something informative in this instance like “Z Axis Limit Switch Active / Move Z-axis to disengage Limit Switch and retry homing operation”.